summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2014-03-05 01:49:40 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2014-03-05 01:49:40 +0000
commit82428924d7a69f23b13d2f342911b960834cf751 (patch)
tree329c5f1fdce84eb85108c7ff85c47337c59e5e53 /mail-mta
parentupdate license to the 11 Nov 2013 version (diff)
downloadgentoo-2-82428924d7a69f23b13d2f342911b960834cf751.tar.gz
gentoo-2-82428924d7a69f23b13d2f342911b960834cf751.tar.bz2
gentoo-2-82428924d7a69f23b13d2f342911b960834cf751.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/opensmtpd/ChangeLog7
-rw-r--r--mail-mta/opensmtpd/opensmtpd-5.4.2_p1.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/mail-mta/opensmtpd/ChangeLog b/mail-mta/opensmtpd/ChangeLog
index 4485c6d54284..43fabcb45d0e 100644
--- a/mail-mta/opensmtpd/ChangeLog
+++ b/mail-mta/opensmtpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-mta/opensmtpd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/ChangeLog,v 1.47 2014/02/28 13:55:40 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/ChangeLog,v 1.48 2014/03/05 01:49:40 zx2c4 Exp $
+
+*opensmtpd-5.4.2_p1 (05 Mar 2014)
+
+ 05 Mar 2014; Jason A. Donenfeld <zx2c4@gentoo.org> +opensmtpd-5.4.2_p1.ebuild:
+ Version bump.
*opensmtpd-5.4.1.201402281146_p1 (28 Feb 2014)
diff --git a/mail-mta/opensmtpd/opensmtpd-5.4.2_p1.ebuild b/mail-mta/opensmtpd/opensmtpd-5.4.2_p1.ebuild
new file mode 100644
index 000000000000..22e42b94970c
--- /dev/null
+++ b/mail-mta/opensmtpd/opensmtpd-5.4.2_p1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.4.2_p1.ebuild,v 1.1 2014/03/05 01:49:40 zx2c4 Exp $
+
+EAPI=5
+
+inherit multilib user flag-o-matic eutils pam toolchain-funcs autotools systemd versionator
+
+DESCRIPTION="Lightweight but featured SMTP daemon from OpenBSD"
+HOMEPAGE="http://www.opensmtpd.org/"
+MY_P="${P}"
+if [ $(get_last_version_component_index) -eq 4 ]; then
+ MY_P="${PN}-$(get_version_component_range 4-)"
+fi
+SRC_URI="http://www.opensmtpd.org/archives/${MY_P/_}.tar.gz"
+
+LICENSE="ISC BSD BSD-1 BSD-2 BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam sqlite +mta"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ pam? ( virtual/pam )
+ sys-libs/db
+ sqlite? ( dev-db/sqlite:3 )
+ dev-libs/libevent
+ app-misc/ca-certificates
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/msmtp[mta]
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/postfix
+ !mail-mta/qmail-ldap
+ !mail-mta/sendmail
+ !mail-mta/ssmtp[mta]
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P/_}
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ tc-export AR
+ AR="$(which "$AR")" econf \
+ --with-privsep-user=smtpd \
+ --with-queue-user=smtpq \
+ --with-privsep-path=/var/empty \
+ --with-sock-dir=/var/run \
+ --sysconfdir=/etc/opensmtpd \
+ --with-ca-file=/etc/ssl/certs/ca-certificates.crt \
+ $(use_with sqlite experimental-sqlite) \
+ $(use_with pam)
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/smtpd.initd smtpd
+ systemd_dounit "${FILESDIR}"/smtpd.{service,socket}
+ use pam && newpamd "${FILESDIR}"/smtpd.pam smtpd
+ if use mta ; then
+ dodir /usr/sbin
+ dosym /usr/sbin/smtpctl /usr/sbin/sendmail
+ dosym /usr/sbin/smtpctl /usr/bin/sendmail
+ dosym /usr/sbin/smtpctl /usr/$(get_libdir)/sendmail
+ fi
+}
+
+pkg_preinst() {
+ enewgroup smtpd 25
+ enewuser smtpd 25 -1 /var/empty smtpd
+ enewgroup smtpq 252
+ enewuser smtpq 252 -1 /var/empty smtpq
+}