summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-05-28 06:07:52 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-05-28 06:07:52 +0000
commit58384eafacad47cd02986042bef1dad12a8f5e70 (patch)
treedc840f235bdc39c31fbd316f8e5cb5cf58626d6c /media-fonts/thaifonts-scalable/thaifonts-scalable-0.4.10.ebuild
parentmask net-analyzer/sonar wrt bug #223479 (diff)
downloadgentoo-2-58384eafacad47cd02986042bef1dad12a8f5e70.tar.gz
gentoo-2-58384eafacad47cd02986042bef1dad12a8f5e70.tar.bz2
gentoo-2-58384eafacad47cd02986042bef1dad12a8f5e70.zip
Initial commit. Fixes bug 216521.
(Portage version: 2.1.5.2)
Diffstat (limited to 'media-fonts/thaifonts-scalable/thaifonts-scalable-0.4.10.ebuild')
-rw-r--r--media-fonts/thaifonts-scalable/thaifonts-scalable-0.4.10.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-fonts/thaifonts-scalable/thaifonts-scalable-0.4.10.ebuild b/media-fonts/thaifonts-scalable/thaifonts-scalable-0.4.10.ebuild
new file mode 100644
index 000000000000..e7abb042408c
--- /dev/null
+++ b/media-fonts/thaifonts-scalable/thaifonts-scalable-0.4.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/thaifonts-scalable/thaifonts-scalable-0.4.10.ebuild,v 1.1 2008/05/28 06:07:52 loki_val Exp $
+
+inherit font
+
+DESCRIPTION="A collection of Free fonts for Thai"
+HOMEPAGE="http://linux.thai.net/projects/thaifonts-scalable"
+SRC_URI="ftp://linux.thai.net/pub/thailinux/software/thai-ttf/thai-ttf-${PV}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/thai-ttf-${PV}"
+FONT_S="${S}"
+FONT_SUFFIX="ttf"
+
+FONT_CONF=( "${FONT_S}/etc/fonts/conf.avail/65-ttf-thai-tlwg.conf"
+ "${FONT_S}/etc/fonts/conf.avail/90-ttf-thai-tlwg-synthetic.conf" )
+
+pkg_postinst() {
+ elog "This font package comes with config files for fontconfig."
+ elog "To enable basic support for this font, do:"
+ elog "eselect fontconfig enable 65-ttf-thai-tlwg.conf"
+ elog "To make this font emulate the thai font of windows, do:"
+ elog "eselect fontconfig enable 90-ttf-thai-tlwg-synthetic.conf"
+}
+
+DOCS=""