summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-02-21 16:15:03 +0000
committerBen de Groot <yngwin@gentoo.org>2015-02-21 16:15:03 +0000
commit3ad72019d409bf3bd33fce9b0ab9045e1b8d5a33 (patch)
tree815315cacab6a94165e7ba6fa32fb1a5b9367252 /media-fonts
parentFix build failure on FreeBSD 10.0, https://github.com/gentoo/gentoo-portage-r... (diff)
downloadgentoo-2-3ad72019d409bf3bd33fce9b0ab9045e1b8d5a33.tar.gz
gentoo-2-3ad72019d409bf3bd33fce9b0ab9045e1b8d5a33.tar.bz2
gentoo-2-3ad72019d409bf3bd33fce9b0ab9045e1b8d5a33.zip
Version bump, which adds unicode support (bug #212544), and uses font.eclass (bug #304621). Ebuild contributed by Ryan Hill. EAPI bumped to 5.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/cronyx-fonts/ChangeLog11
-rw-r--r--media-fonts/cronyx-fonts/cronyx-fonts-2.3.8.ebuild26
2 files changed, 34 insertions, 3 deletions
diff --git a/media-fonts/cronyx-fonts/ChangeLog b/media-fonts/cronyx-fonts/ChangeLog
index 13bd6b154a7f..1a5811bc99e8 100644
--- a/media-fonts/cronyx-fonts/ChangeLog
+++ b/media-fonts/cronyx-fonts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-fonts/cronyx-fonts
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-fonts/cronyx-fonts/ChangeLog,v 1.19 2007/07/22 07:52:58 dirtyepic Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/cronyx-fonts/ChangeLog,v 1.20 2015/02/21 16:15:03 yngwin Exp $
+
+*cronyx-fonts-2.3.8 (21 Feb 2015)
+
+ 21 Feb 2015; Ben de Groot <yngwin@gentoo.org> +cronyx-fonts-2.3.8.ebuild:
+ Version bump, which adds unicode support (bug #212544), and uses font.eclass
+ (bug #304621). Ebuild contributed by Ryan Hill. EAPI bumped to 5.
22 Jul 2007; Ryan Hill <dirtyepic@gentoo.org>
-cronyx-fonts-2.3.1-r1.ebuild, cronyx-fonts-2.3.1-r2.ebuild:
@@ -83,4 +89,3 @@
+cronyx-fonts-2.3.1.ebuild:
Initial import. Ebuild submitted by Alexey Spiridonov <lesha@netman.ru>,
closing bug #23958
-
diff --git a/media-fonts/cronyx-fonts/cronyx-fonts-2.3.8.ebuild b/media-fonts/cronyx-fonts/cronyx-fonts-2.3.8.ebuild
new file mode 100644
index 000000000000..b2c285d0ab10
--- /dev/null
+++ b/media-fonts/cronyx-fonts/cronyx-fonts-2.3.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/cronyx-fonts/cronyx-fonts-2.3.8.ebuild,v 1.1 2015/02/21 16:15:03 yngwin Exp $
+
+EAPI=5
+FONT_PN="cronyx"
+inherit eutils font font-ebdftopcf
+
+MY_P="xfonts-cronyx_${PV}"
+DESCRIPTION="Cronyx Cyrillic bitmap fonts for X"
+HOMEPAGE="http://packages.debian.org/source/sid/xfonts-cronyx"
+SRC_URI="mirror://debian/pool/main/x/xfonts-cronyx/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/x/xfonts-cronyx/${MY_P}-6.diff.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${MY_P//_/-}.orig"
+FONT_S="${S}/75dpi ${S}/100dpi ${S}/misc"
+DOCS="Changelog.en xcyr.README.* xrus.README"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${MY_P}-6.diff
+}