summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-04-13 13:25:58 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-04-13 13:25:58 +0000
commitb9bc2dda85aa05913bda6ab866984357429e720e (patch)
tree9cf11f67ef6a9263c5e89fdc0593fac473c7dc31 /media-gfx/asymptote/files
parentAdd a warning to let the user know he has to be in the messagebus group. Fix ... (diff)
downloadgentoo-2-b9bc2dda85aa05913bda6ab866984357429e720e.tar.gz
gentoo-2-b9bc2dda85aa05913bda6ab866984357429e720e.tar.bz2
gentoo-2-b9bc2dda85aa05913bda6ab866984357429e720e.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'media-gfx/asymptote/files')
-rw-r--r--media-gfx/asymptote/files/asymptote-1.92-configure-ac.patch32
-rw-r--r--media-gfx/asymptote/files/asymptote-1.92-xdg-utils.patch22
2 files changed, 54 insertions, 0 deletions
diff --git a/media-gfx/asymptote/files/asymptote-1.92-configure-ac.patch b/media-gfx/asymptote/files/asymptote-1.92-configure-ac.patch
new file mode 100644
index 000000000000..c9be065665b0
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.92-configure-ac.patch
@@ -0,0 +1,32 @@
+Index: asymptote-1.92/configure.ac
+===================================================================
+--- asymptote-1.92.orig/configure.ac
++++ asymptote-1.92/configure.ac
+@@ -148,7 +148,7 @@ if test "x$ac_cv_use_gc" != "xno" ; then
+ fi
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+ AC_MSG_NOTICE([enabling system $GCNAME])],[
+@@ -215,7 +215,17 @@ AC_MSG_ERROR([*** Please install libm on
+ AC_CHECK_LIB([z], [deflate],,
+ AC_MSG_ERROR([*** Please install libz on your system ***]))
+ AC_CHECK_LIB([pthread], [pthread_create])
+-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
++
++AC_ARG_WITH(sigsegv,
++ [ --with-sigsegv use libsigsegv],
++ [with_sigsegv=$withval],
++ [with_sigsegv="no"])
++if test "$with_sigsegv" = "yes"; then
++AC_CHECK_HEADER([sigsegv.h],
++ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
++ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
++fi
++
+ AC_CHECK_LIB([rt], [sched_yield])
+
+ AC_ARG_ENABLE(readline,
diff --git a/media-gfx/asymptote/files/asymptote-1.92-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-1.92-xdg-utils.patch
new file mode 100644
index 000000000000..3e18c60ad452
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.92-xdg-utils.patch
@@ -0,0 +1,22 @@
+Index: asymptote-1.92/settings.cc
+===================================================================
+--- asymptote-1.92.orig/settings.cc
++++ asymptote-1.92/settings.cc
+@@ -88,14 +88,14 @@ string systemDir=ASYMPTOTE_SYSDIR;
+ bool msdos=false;
+ string HOME="HOME";
+ const char pathSeparator=':';
+-string defaultPSViewer="gv";
++string defaultPSViewer="xdg-open";
+ #ifdef __APPLE__
+ string defaultPDFViewer="open";
+ #else
+-string defaultPDFViewer="acroread";
++string defaultPDFViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultAnimate="animate";
+ string docdir=ASYMPTOTE_DOCDIR;
+ void queryRegistry() {}