summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-09-07 13:08:57 +0000
committerMarkus Meier <maekke@gentoo.org>2008-09-07 13:08:57 +0000
commit3253b3027ff9cc59f9a2dad6bd8a09045db6c80e (patch)
tree671ea21cceafab3e4b439702c0902e13c2a57ed3 /media-gfx/comix/comix-3.6.5.ebuild
parentImport from science overlay (diff)
downloadgentoo-2-3253b3027ff9cc59f9a2dad6bd8a09045db6c80e.tar.gz
gentoo-2-3253b3027ff9cc59f9a2dad6bd8a09045db6c80e.tar.bz2
gentoo-2-3253b3027ff9cc59f9a2dad6bd8a09045db6c80e.zip
bump to 3.6.5, bug #236324
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5 i686)
Diffstat (limited to 'media-gfx/comix/comix-3.6.5.ebuild')
-rw-r--r--media-gfx/comix/comix-3.6.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/comix/comix-3.6.5.ebuild b/media-gfx/comix/comix-3.6.5.ebuild
new file mode 100644
index 000000000000..1d59e6ca96d2
--- /dev/null
+++ b/media-gfx/comix/comix-3.6.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/comix/comix-3.6.5.ebuild,v 1.1 2008/09/07 13:08:57 maekke Exp $
+
+inherit toolchain-funcs gnome2 eutils
+
+DESCRIPTION="A GTK image viewer specifically designed to handle comic books."
+HOMEPAGE="http://comix.sourceforge.net"
+SRC_URI="mirror://sourceforge/comix/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="rar"
+RDEPEND=">=dev-python/imaging-1.1.4
+ >=dev-python/pygtk-2.8.0
+ rar? ( app-arch/unrar )"
+
+src_compile() {
+ einfo "Nothing to be compiled."
+}
+
+src_install() {
+ dodir /usr
+ python install.py install --no-mime --installdir "${D}"usr || die
+ insinto /usr/share/mime/packages/
+ doins "${S}"/mime/comix.xml || die
+ insinto /etc/gconf/schemas/
+ doins "${S}"/mime/comicbook.schemas || die
+ dobin "${S}"/mime/comicthumb || die
+ dodoc ChangeLog README || die
+}