summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-08-25 13:43:50 +0000
committerMamoru Komachi <usata@gentoo.org>2003-08-25 13:43:50 +0000
commit7228969141387b9bda8fc9a1e7804b950d94d7f0 (patch)
tree825652e3a0fd0d546fc44ac8aa20078556daab4c /media-gfx/fbv
parentnew ebuild, closing Bug #27281 (diff)
downloadgentoo-2-7228969141387b9bda8fc9a1e7804b950d94d7f0.tar.gz
gentoo-2-7228969141387b9bda8fc9a1e7804b950d94d7f0.tar.bz2
gentoo-2-7228969141387b9bda8fc9a1e7804b950d94d7f0.zip
new ebuild, closing Bug #27281
Diffstat (limited to 'media-gfx/fbv')
-rw-r--r--media-gfx/fbv/ChangeLog9
-rw-r--r--media-gfx/fbv/Manifest3
-rw-r--r--media-gfx/fbv/fbv-0.99.ebuild42
-rw-r--r--media-gfx/fbv/files/digest-fbv-0.991
4 files changed, 54 insertions, 1 deletions
diff --git a/media-gfx/fbv/ChangeLog b/media-gfx/fbv/ChangeLog
new file mode 100644
index 000000000000..e5bb90d0c420
--- /dev/null
+++ b/media-gfx/fbv/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-gfx/fbv
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbv/ChangeLog,v 1.1 2003/08/25 13:43:46 usata Exp $
+
+*fbv-0.99 (25 Aug 2003)
+
+ 25 Aug 2003; Mamoru KOMACHI <usata@gentoo.org> fbv-0.99.ebuild:
+ Initial import. Closing Bug #27281
+
diff --git a/media-gfx/fbv/Manifest b/media-gfx/fbv/Manifest
index d7b1d42b555b..03a0e44ac18b 100644
--- a/media-gfx/fbv/Manifest
+++ b/media-gfx/fbv/Manifest
@@ -1,2 +1,3 @@
-MD5 e42b93f19f5c431b528280beabf218a8 fbv-0.99.ebuild 1003
+MD5 3d6a9572f42c557ab2b4401a0ffe0cfc fbv-0.99.ebuild 992
+MD5 658004bfd1babcfa7305c7202926a949 ChangeLog 337
MD5 fddf15ff0ff3ee14782881f4425e8b36 files/digest-fbv-0.99 59
diff --git a/media-gfx/fbv/fbv-0.99.ebuild b/media-gfx/fbv/fbv-0.99.ebuild
new file mode 100644
index 000000000000..dba3d242b4bd
--- /dev/null
+++ b/media-gfx/fbv/fbv-0.99.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbv/fbv-0.99.ebuild,v 1.1 2003/08/25 13:43:46 usata Exp $
+
+IUSE="png gif jpeg"
+
+DESCRIPTION="fbv is a simple program to view pictures on a linux framebuffer device"
+HOMEPAGE="http://s-tech.elsat.net.pl/fbv/"
+SRC_URI="http://s-tech.elsat.net.pl/fbv//${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="gif? ( media-libs/libungif )
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )"
+
+src_compile() {
+
+ local myconf
+
+ use png || myconf="${myconf} --without-libpng"
+ use gif || myconf="${myconf} --without-libungif"
+ use jpeg || myconf="${myconf} --without-libjpeg"
+
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die
+ emake CC="${CC} ${CFLAGS}" || die
+}
+
+src_install() {
+
+ dobin fbv
+ doman fbv.1
+
+ dodoc ChangeLog README TODO VERSION
+}
diff --git a/media-gfx/fbv/files/digest-fbv-0.99 b/media-gfx/fbv/files/digest-fbv-0.99
new file mode 100644
index 000000000000..5895e640cda9
--- /dev/null
+++ b/media-gfx/fbv/files/digest-fbv-0.99
@@ -0,0 +1 @@
+MD5 fd237cb79ab26d30a7f8bb526a78bd0a fbv-0.99.tar.gz 14466