summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-06 17:48:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-06 17:48:48 +0000
commitfa0d9fec6bd05aab48bec90f589cbaa836e3c5da (patch)
treefd7efc6508630f2d8e070b413f06a1195440c41c /media-gfx/gimmage/gimmage-0.2.3.ebuild
parentStable for HPPA (bug #325593). (diff)
downloadgentoo-2-fa0d9fec6bd05aab48bec90f589cbaa836e3c5da.tar.gz
gentoo-2-fa0d9fec6bd05aab48bec90f589cbaa836e3c5da.tar.bz2
gentoo-2-fa0d9fec6bd05aab48bec90f589cbaa836e3c5da.zip
Fix desktop entry and USE debug handling.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/gimmage/gimmage-0.2.3.ebuild')
-rw-r--r--media-gfx/gimmage/gimmage-0.2.3.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/media-gfx/gimmage/gimmage-0.2.3.ebuild b/media-gfx/gimmage/gimmage-0.2.3.ebuild
index 5951000ef6b3..11869f91b330 100644
--- a/media-gfx/gimmage/gimmage-0.2.3.ebuild
+++ b/media-gfx/gimmage/gimmage-0.2.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimmage/gimmage-0.2.3.ebuild,v 1.6 2008/11/30 17:51:59 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimmage/gimmage-0.2.3.ebuild,v 1.7 2010/08/06 17:48:47 ssuominen Exp $
-inherit eutils autotools
+EAPI=2
+inherit autotools eutils
DESCRIPTION="A slim GTK-based image browser"
HOMEPAGE="http://gimmage.berlios.de/"
@@ -21,19 +22,21 @@ DEPEND="${RDEPEND}
sys-devel/gettext
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
- epatch "${FILESDIR}"/${P}-as-needed.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-desktop-entry.patch
eautoreconf
}
-src_compile() {
- econf $(use_enable debug) || die "econf failed"
- emake || die "emake failed"
+src_configure() {
+ local myconf
+ use debug && myconf="--enable-debug"
+
+ econf ${myconf}
}
src_install() {
- einstall || die "einstall failed"
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
}