summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-02-12 22:55:30 +0000
committerTod Neidt <tod@gentoo.org>2002-02-12 22:55:30 +0000
commitd88bb4a06b8dcb866d3f5bcc407fefe54233d615 (patch)
treef9f0f587980552cea76c19eb2d017a3d0db81282 /media-gfx/gnuplot
parentnew (based on user submission): bochs is an open source xf86 virtual machine (diff)
downloadgentoo-2-d88bb4a06b8dcb866d3f5bcc407fefe54233d615.tar.gz
gentoo-2-d88bb4a06b8dcb866d3f5bcc407fefe54233d615.tar.bz2
gentoo-2-d88bb4a06b8dcb866d3f5bcc407fefe54233d615.zip
Added support for Gnu plotutils library to gnuplot. Plotutils dependency and configuration is conditional on 'plotutils' in the USE variable. Also changed pkg_postinst echo's to einfo.
Diffstat (limited to 'media-gfx/gnuplot')
-rw-r--r--media-gfx/gnuplot/ChangeLog9
-rw-r--r--media-gfx/gnuplot/files/digest-gnuplot-3.7.1-r21
-rw-r--r--media-gfx/gnuplot/gnuplot-3.7.1-r2.ebuild86
3 files changed, 95 insertions, 1 deletions
diff --git a/media-gfx/gnuplot/ChangeLog b/media-gfx/gnuplot/ChangeLog
index e508ac9122ce..48bcd0a25499 100644
--- a/media-gfx/gnuplot/ChangeLog
+++ b/media-gfx/gnuplot/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for media-gfx/gnuplot
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.1 2002/02/01 21:53:29 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.2 2002/02/12 22:55:30 tod Exp $
+*gnuplot-3.7.1-r2 (12 Feb 2002)
+
+ 12 Feb 2002; T.Neidt <tod@gentoo.org> ChangeLog, gnuplot-3.7.1-r2.ebuild :
+
+ Added gnu plotutils support for gnuplot. Dependency and configuration for
+ plotutils requires 'plotutils' to be in the USE variable.
+
*gnuplot-3.7.1-r1 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/media-gfx/gnuplot/files/digest-gnuplot-3.7.1-r2 b/media-gfx/gnuplot/files/digest-gnuplot-3.7.1-r2
new file mode 100644
index 000000000000..b393482c3a52
--- /dev/null
+++ b/media-gfx/gnuplot/files/digest-gnuplot-3.7.1-r2
@@ -0,0 +1 @@
+MD5 30798b4c14ea734969a86ee41a9c1dca gnuplot-3.7.1.tar.gz 1319233
diff --git a/media-gfx/gnuplot/gnuplot-3.7.1-r2.ebuild b/media-gfx/gnuplot/gnuplot-3.7.1-r2.ebuild
new file mode 100644
index 000000000000..761ea69d2113
--- /dev/null
+++ b/media-gfx/gnuplot/gnuplot-3.7.1-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/gnuplot-3.7.1-r2.ebuild,v 1.1 2002/02/12 22:55:30 tod Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Quick and useful plotting program"
+SRC_URI="ftp://ftp.gnuplot.org/pub/gnuplot/${P}.tar.gz"
+HOMEPAGE="http://www.gnuplot.org"
+
+DEPEND="media-libs/libpng
+ plotutils? ( media-libs/plotutils )
+ readline? ( sys-libs/readline )
+ X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )"
+
+src_compile() {
+ local myvar
+ #--with-lasergnu flag seems to be broken and I'm too lazy to fix now
+ #myvar=" --with-png --without-gd --with-lasergnu"
+ myvar=" --with-png --without-gd --with-plot=/usr/lib"
+ #--with-plot enables the Gnu plotutils library
+ #need to specify path to differentiate from Unix plot
+ if [ -z "`use plotutils`" ]
+ then
+ myvar="${myvar} --without-plot"
+ else
+ myvar="${myvar} --with-plot=/usr/lib"
+ fi
+ if [ -z "`use X`" ]
+ then
+ myvar="${myvar} --without-x"
+ else
+ myvar="${myvar} --with-x"
+ fi
+ if [ -z "`use readline`" ]
+ then
+ #use the built-in readline
+ myvar="${myvar} --with-readline"
+ else
+ #use gnu readline
+ myvar="${myvar} --with-readline=gnu"
+ fi
+ if [ -z "`use svga`" ]
+ then
+ myvar="${myvar} --without-linux-vga"
+ else
+ myvar="${myvar} --with-linux-vga"
+ fi
+ ./configure \
+ ${myvar} \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share/gnuplot \
+ --mandir=/usr/share/man || die
+ mv Makefile Makefile.orig
+ sed -e 's/datadir = \/usr/datadir = ${prefix}/' \
+ -e 's/mandir = \/usr/mandir = ${prefix}/' \
+ Makefile.orig > Makefile
+ cd docs
+ mv Makefile Makefile.orig
+ sed -e 's/datadir = \/usr/datadir = ${prefix}/' Makefile.orig > Makefile
+ cd ..
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+}
+
+pkg_postinst() {
+ if [ "`use svga`" ]
+ then
+ einfo ""
+ einfo "*****************************************************************"
+ einfo " In order to enable ordinary users to use SVGA console graphics"
+ einfo " gnuplot needs to be set up as setuid root. Please note that"
+ einfo " this is usually considered to be a security hazard."
+ einfo " As root, manually chmod u+s /usr/bin/gnuplot"
+ einfo "*****************************************************************"
+ einfo
+ fi
+}
+
+