summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2007-12-03 16:40:40 +0000
committerMarkus Meier <maekke@gentoo.org>2007-12-03 16:40:40 +0000
commit4941e2435eaf4e7d8545f8ae6e8a4017f1d02f96 (patch)
treeda893907b0e7ad6bc716c1d0a5e4b8a1addb3adc /media-gfx/hugin/hugin-0.6.1-r2.ebuild
parentbump (diff)
downloadgentoo-2-4941e2435eaf4e7d8545f8ae6e8a4017f1d02f96.tar.gz
gentoo-2-4941e2435eaf4e7d8545f8ae6e8a4017f1d02f96.tar.bz2
gentoo-2-4941e2435eaf4e7d8545f8ae6e8a4017f1d02f96.zip
revision bump, fix as-needed (bug #180381), also fix security bug #195996 for 0.7
(Portage version: 2.1.4_rc6)
Diffstat (limited to 'media-gfx/hugin/hugin-0.6.1-r2.ebuild')
-rw-r--r--media-gfx/hugin/hugin-0.6.1-r2.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/media-gfx/hugin/hugin-0.6.1-r2.ebuild b/media-gfx/hugin/hugin-0.6.1-r2.ebuild
new file mode 100644
index 000000000000..8c2f00078005
--- /dev/null
+++ b/media-gfx/hugin/hugin-0.6.1-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-0.6.1-r2.ebuild,v 1.1 2007/12/03 16:40:39 maekke Exp $
+
+inherit wxwidgets eutils autotools libtool
+
+DESCRIPTION="GUI for the creation & processing of panoramic images"
+HOMEPAGE="http://hugin.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2 SIFT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="unicode debug enblend sift"
+
+DEPEND=">=media-libs/libpano12-2.8.4
+ >=dev-libs/boost-1.30.0
+ =x11-libs/wxGTK-2.6*
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ enblend? ( >=media-gfx/enblend-2.4 )
+ sift? ( media-gfx/autopano-sift )"
+
+pkg_setup() {
+ if ! built_with_use --missing true dev-libs/boost threads ; then
+ local msg="Build dev-libs/boost with USE=threads"
+ eerror "$msg"
+ die "$msg"
+ fi
+ if ! use enblend; then
+ elog "It is recommended to emerge this package with the"
+ elog "enblend use flag to install media-gfx/enblend"
+ elog "that blends the seams between images in a panorama."
+ fi
+ if ! use sift; then
+ elog "It is recommended to emerge this package with the"
+ elog "sift use flag to install media-gfx/autopano-sift"
+ elog "that produces control points between images in a"
+ elog "panorama."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e 's/autopanog\.exe/autopanog/' "${S}"/src/include/hugin/config_defaults.h
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-1_0.6.1-1.1.patch"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_compile() {
+ export WX_GTK_VER="2.6"
+
+ if use unicode; then
+ need-wxwidgets unicode || die "Emerge wxGTK with unicode in USE"
+ else
+ need-wxwidgets gtk2 || die "Emerge wxGTK with gtk2 in USE"
+ fi
+
+ myconf="`use_with unicode`
+ `use_enable debug`"
+
+ econf --with-wx-config="${WX_CONFIG}" ${myconf} || die "configure failed"
+ emake || die "compiling failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS BUGS README TODO
+}