summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-01-09 17:58:57 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-01-09 17:58:57 +0000
commit874a453e572b113ad04bf53680ae6ee45f32aec1 (patch)
treee6f31446c08980ba7af0966437f72d44b35d5823 /media-gfx/jp2a/jp2a-1.0.6-r1.ebuild
parentFix nasm detection, bug 204505 (diff)
downloadgentoo-2-874a453e572b113ad04bf53680ae6ee45f32aec1.tar.gz
gentoo-2-874a453e572b113ad04bf53680ae6ee45f32aec1.tar.bz2
gentoo-2-874a453e572b113ad04bf53680ae6ee45f32aec1.zip
Make CURL dependency optional, ebuild enhancement by Nadim Kobeissi <nadim@keihatsu.org>.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'media-gfx/jp2a/jp2a-1.0.6-r1.ebuild')
-rw-r--r--media-gfx/jp2a/jp2a-1.0.6-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-gfx/jp2a/jp2a-1.0.6-r1.ebuild b/media-gfx/jp2a/jp2a-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..203b991a5a09
--- /dev/null
+++ b/media-gfx/jp2a/jp2a-1.0.6-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jp2a/jp2a-1.0.6-r1.ebuild,v 1.1 2008/01/09 17:58:57 chainsaw Exp $
+
+DESCRIPTION="JPEG image to ASCII art converter"
+HOMEPAGE="http://csl.sublevel3.org/jp2a/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl"
+DEPEND="media-libs/jpeg
+ curl? ( net-misc/curl )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf $(use_enable curl) || die
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dohtml man/jp2a.html
+}