summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-22 15:58:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-22 15:58:08 +0000
commit57025b767f5df102706a1adfcb1b29eefc8efe38 (patch)
tree38dffdb4ea299760000c9573ada289776ddb5c02 /media-gfx/llgal
parentgnome: prefer http mirror over ftp mirror (diff)
downloadgentoo-2-57025b767f5df102706a1adfcb1b29eefc8efe38.tar.gz
gentoo-2-57025b767f5df102706a1adfcb1b29eefc8efe38.tar.bz2
gentoo-2-57025b767f5df102706a1adfcb1b29eefc8efe38.zip
version bump, by Massimo Burcheri <massimo.burcheri@gmx.de>, bug #355183
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/llgal')
-rw-r--r--media-gfx/llgal/ChangeLog9
-rw-r--r--media-gfx/llgal/llgal-0.13.16.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/media-gfx/llgal/ChangeLog b/media-gfx/llgal/ChangeLog
index f0c26232420a..2f7f205a1193 100644
--- a/media-gfx/llgal/ChangeLog
+++ b/media-gfx/llgal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/llgal
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/llgal/ChangeLog,v 1.27 2009/10/13 17:14:02 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/llgal/ChangeLog,v 1.28 2011/02/22 15:58:08 aballier Exp $
+
+*llgal-0.13.16 (22 Feb 2011)
+
+ 22 Feb 2011; Alexis Ballier <aballier@gentoo.org> +llgal-0.13.16.ebuild:
+ version bump, by Massimo Burcheri <massimo.burcheri@gmx.de>, bug #355183
13 Oct 2009; Alexis Ballier <aballier@gentoo.org> -llgal-0.13.13.ebuild:
remove old
diff --git a/media-gfx/llgal/llgal-0.13.16.ebuild b/media-gfx/llgal/llgal-0.13.16.ebuild
new file mode 100644
index 000000000000..54c08f31a024
--- /dev/null
+++ b/media-gfx/llgal/llgal-0.13.16.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/llgal/llgal-0.13.16.ebuild,v 1.1 2011/02/22 15:58:08 aballier Exp $
+
+inherit perl-module
+
+DESCRIPTION="Command-line static web gallery generator"
+HOMEPAGE="http://home.gna.org/llgal"
+SRC_URI="http://download.gna.org/llgal/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="exif"
+
+LINS="de en it fr"
+for i in ${LINS}; do
+ IUSE="${IUSE} linguas_${i}"
+done
+
+RDEPEND="media-gfx/imagemagick
+ dev-lang/perl
+ dev-perl/ImageSize
+ dev-perl/URI
+ dev-perl/Locale-gettext
+ exif? ( media-libs/exiftool )"
+
+src_compile() {
+ emake PREFIX=/usr SYSCONFDIR=/etc MANDIR=/usr/share/man \
+ PERL_INSTALLDIRS=vendor || die "Failed to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LOCALES="${LINGUAS}" PREFIX=/usr SYSCONFDIR=/etc \
+ PERL_INSTALLDIRS=vendor MANDIR=/usr/share/man \
+ install install-doc install-man DOCDIR=/usr/share/doc/${PF}/ \
+ || die "Failed to install"
+ fixlocalpod
+ dodoc Changes
+}