summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2008-12-18 03:14:08 +0000
committerJustin Bronder <jsbronder@gentoo.org>2008-12-18 03:14:08 +0000
commited90d102b76d62ebe08700d676db827cdf561956 (patch)
treea5f887e5b5578792b939035bf65004d5fefdf0e6 /media-gfx/openmesh
parentremove old versions (diff)
downloadgentoo-2-ed90d102b76d62ebe08700d676db827cdf561956.tar.gz
gentoo-2-ed90d102b76d62ebe08700d676db827cdf561956.tar.bz2
gentoo-2-ed90d102b76d62ebe08700d676db827cdf561956.zip
Cleanup repoman warnings and old versions. Fix openmesh-1.{0.0,9.5} to work with newer acgmake.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'media-gfx/openmesh')
-rw-r--r--media-gfx/openmesh/ChangeLog7
-rw-r--r--media-gfx/openmesh/openmesh-1.0.0.ebuild22
-rw-r--r--media-gfx/openmesh/openmesh-1.9.5.ebuild24
-rw-r--r--media-gfx/openmesh/openmesh-1.9.6-r1.ebuild6
-rw-r--r--media-gfx/openmesh/openmesh-1.9.6.ebuild58
5 files changed, 33 insertions, 84 deletions
diff --git a/media-gfx/openmesh/ChangeLog b/media-gfx/openmesh/ChangeLog
index c32d01957888..2ed69ff9873a 100644
--- a/media-gfx/openmesh/ChangeLog
+++ b/media-gfx/openmesh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/openmesh
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/ChangeLog,v 1.10 2008/12/04 02:09:10 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/ChangeLog,v 1.11 2008/12/18 03:14:08 jsbronder Exp $
+
+ 18 Dec 2008; Justin Bronder <jsbronder@gentoo.org> openmesh-1.0.0.ebuild,
+ openmesh-1.9.5.ebuild, -openmesh-1.9.6.ebuild, openmesh-1.9.6-r1.ebuild:
+ Cleanup repoman warnings and old versions. Fix openmesh-1.{0.0,9.5} to work
+ with newer acgmake.
*openmesh-1.9.6-r1 (04 Dec 2008)
diff --git a/media-gfx/openmesh/openmesh-1.0.0.ebuild b/media-gfx/openmesh/openmesh-1.0.0.ebuild
index 48eb32605964..1bab63ca58de 100644
--- a/media-gfx/openmesh/openmesh-1.0.0.ebuild
+++ b/media-gfx/openmesh/openmesh-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-1.0.0.ebuild,v 1.4 2008/08/11 23:40:23 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-1.0.0.ebuild,v 1.5 2008/12/18 03:14:08 jsbronder Exp $
EAPI="1"
inherit eutils
@@ -23,9 +23,9 @@ DEPEND="dev-util/acgmake
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/${P}-gcc41.patch || die
+ epatch "${FILESDIR}"/${P}-gcc41.patch || die
if ! use qt4
then
@@ -40,14 +40,15 @@ src_compile() {
acgmake ${myconf} || die
# fix insecure runpaths
- TMPDIR=${S} scanelf -BXRr ${S} -o /dev/null || die
+ TMPDIR=${S} scanelf -BXRr "${S}" -o /dev/null || die
}
src_install() {
- into /usr
- dolib Core/Linux_gcc_dbg/libOpenMesh_Core.so
- dolib Tools/Linux_gcc_dbg/libOpenMesh_Tools.so
- dolib Tools/Subdivider/Adaptive/Composite/Linux_gcc_dbg/libOpenMesh_Tools_Subdivider_Adaptive_Composite.so
+ local l
+
+ for l in $(find "${S}"/{Core,Tools} -name '*.so'); do
+ dolib ${l} || die
+ done
make clean
@@ -56,7 +57,6 @@ src_install() {
dodir /usr/include/${MY_PN}
- cp -a Core ${D}/usr/include/${MY_PN}
- cp -a Tools ${D}/usr/include/${MY_PN}
-
+ cp -a Core "${D}"/usr/include/${MY_PN}
+ cp -a Tools "${D}"/usr/include/${MY_PN}
}
diff --git a/media-gfx/openmesh/openmesh-1.9.5.ebuild b/media-gfx/openmesh/openmesh-1.9.5.ebuild
index ea4552c411ec..6079df6f103d 100644
--- a/media-gfx/openmesh/openmesh-1.9.5.ebuild
+++ b/media-gfx/openmesh/openmesh-1.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-1.9.5.ebuild,v 1.3 2008/08/11 23:40:23 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-1.9.5.ebuild,v 1.4 2008/12/18 03:14:08 jsbronder Exp $
EAPI="1"
inherit eutils
@@ -24,7 +24,7 @@ DEPEND=">=dev-util/acgmake-1.2-r2
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
use qt4 || sed -i "s:Apps::" ACGMakefile
}
@@ -38,22 +38,24 @@ src_compile() {
acgmake -env || die
# fix insecure runpaths
- TMPDIR=${S} scanelf -BXRr ${S} -o /dev/null || die
+ TMPDIR="${S}" scanelf -BXRr "${S}" -o /dev/null || die
}
src_install() {
- into /usr
- dolib Core/Linux_gcc_env/libOpenMesh_Core.so
- dolib Tools/Linux_gcc_env/libOpenMesh_Tools.so
- dolib Tools/Subdivider/Adaptive/Composite/Linux_gcc_env/libOpenMesh_Tools_Subdivider_Adaptive_Composite.so
+ local l
+
+ for l in $(find "${S}"/{Core,Tools} -name '*.so'); do
+ dolib ${l} || die
+ done
make clean
- find . -name 'ACGMakefile' -delete
- find . -name '*.vcproj' -delete
+ find . -name 'ACGMakefile' -delete || die
+ find . -name '*.vcproj' -delete || die
+ rm -rf $(find "${S}" -type d -name 'Linux_gcc*_env') || die
dodir /usr/include/${MY_PN}
- cp -a Core ${D}/usr/include/${MY_PN}
- cp -a Tools ${D}/usr/include/${MY_PN}
+ cp -a Core "${D}"/usr/include/${MY_PN}
+ cp -a Tools "${D}"/usr/include/${MY_PN}
}
diff --git a/media-gfx/openmesh/openmesh-1.9.6-r1.ebuild b/media-gfx/openmesh/openmesh-1.9.6-r1.ebuild
index 00b29bd65c7e..941112255fc5 100644
--- a/media-gfx/openmesh/openmesh-1.9.6-r1.ebuild
+++ b/media-gfx/openmesh/openmesh-1.9.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-1.9.6-r1.ebuild,v 1.1 2008/12/04 02:09:10 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-1.9.6-r1.ebuild,v 1.2 2008/12/18 03:14:08 jsbronder Exp $
EAPI="2"
inherit eutils
@@ -36,14 +36,14 @@ src_compile() {
acgmake -env || die
# fix insecure runpaths
- TMPDIR=${S} scanelf -BXRr "${S}" -o /dev/null || die
+ TMPDIR="${S}" scanelf -BXRr "${S}" -o /dev/null || die
}
src_install() {
local l
for l in $(find "${S}"/{Core,Tools} -name '*.so'); do
- dolib ${l}
+ dolib ${l} || die
done
# Clean up manually as acgmake doesn't do a decent job.
diff --git a/media-gfx/openmesh/openmesh-1.9.6.ebuild b/media-gfx/openmesh/openmesh-1.9.6.ebuild
deleted file mode 100644
index d353181a9f79..000000000000
--- a/media-gfx/openmesh/openmesh-1.9.6.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-1.9.6.ebuild,v 1.1 2008/11/25 21:19:52 jsbronder Exp $
-
-EAPI="1"
-inherit eutils
-
-MY_PN="OpenMesh"
-S=${WORKDIR}/${MY_PN}
-DESCRIPTION="A generic and efficient data structure for representing and manipulating polygonal meshes"
-HOMEPAGE="http://www.openmesh.org/"
-SRC_URI="http://www-i8.informatik.rwth-aachen.de/${MY_PN}/downloads/${MY_PN}-${PV}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="qt4 debug"
-
-RDEPEND="qt4? ( || ( x11-libs/qt-gui:4 =x11-libs/qt-4.3* ) )"
-DEPEND=">=dev-util/acgmake-1.2-r2
- >=sys-apps/findutils-4.3.0
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- use qt4 || sed -i "s:Apps::" ACGMakefile
-}
-
-src_compile() {
- if use debug; then
- export CXXDEFS="-UNDEBUG -DDEBUG"
- else
- export CXXDEFS="-DNDEBUG -UDEBUG"
- fi
- acgmake -env || die
-
- # fix insecure runpaths
- TMPDIR=${S} scanelf -BXRr "${S}" -o /dev/null || die
-}
-
-src_install() {
- into /usr
- dolib Core/Linux_gcc_env/libOpenMesh_Core.so
- dolib Tols/Linux_gcc_env/libOpenMesh_Tools.so
- dolib Tools/Subdivider/Adaptive/Composite/Linux_gcc_env/libOpenMesh_Tools_Subdivider_Adaptive_Composite.so
-
- make clean
-
- find . -name 'ACGMakefile' -delete
- find . -name '*.vcproj' -delete
-
- dodir /usr/include/${MY_PN}
-
- cp -a Core "${D}"/usr/include/${MY_PN}
- cp -a Tools "${D}"/usr/include/${MY_PN}
-}