summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-28 10:49:07 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-28 10:49:07 +0000
commit73b19acec56ea2834d915de794f0e11f9f0ae597 (patch)
treeef6688c47793daf2e91a99eab33dbb9382e951aa /media-gfx/pencil
parentAdd efiemu useflag for grub2. Fixes bug #380863. (diff)
downloadgentoo-2-73b19acec56ea2834d915de794f0e11f9f0ae597.tar.gz
gentoo-2-73b19acec56ea2834d915de794f0e11f9f0ae597.tar.bz2
gentoo-2-73b19acec56ea2834d915de794f0e11f9f0ae597.zip
Initial commit. Bug #232673. Thanks to Samuli Suominen and Matteo 'The Peach'
Pescarin for the ebuilds (Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/pencil')
-rw-r--r--media-gfx/pencil/ChangeLog11
-rw-r--r--media-gfx/pencil/metadata.xml12
-rw-r--r--media-gfx/pencil/pencil-0.4.4_beta.ebuild40
3 files changed, 63 insertions, 0 deletions
diff --git a/media-gfx/pencil/ChangeLog b/media-gfx/pencil/ChangeLog
new file mode 100644
index 000000000000..a545b2b2e3c8
--- /dev/null
+++ b/media-gfx/pencil/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-gfx/pencil
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pencil/ChangeLog,v 1.1 2011/08/28 10:49:07 hwoarang Exp $
+
+*pencil-0.4.4_beta (28 Aug 2011)
+
+ 28 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +pencil-0.4.4_beta.ebuild,
+ +metadata.xml:
+ Initial commit. Bug #232673. Thanks to Samuli Suominen and Matteo 'The Peach'
+ Pescarin for the ebuilds
+
diff --git a/media-gfx/pencil/metadata.xml b/media-gfx/pencil/metadata.xml
new file mode 100644
index 000000000000..d5f9562e2df2
--- /dev/null
+++ b/media-gfx/pencil/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-gfx/pencil/pencil-0.4.4_beta.ebuild b/media-gfx/pencil/pencil-0.4.4_beta.ebuild
new file mode 100644
index 000000000000..7ffc01ca2859
--- /dev/null
+++ b/media-gfx/pencil/pencil-0.4.4_beta.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pencil/pencil-0.4.4_beta.ebuild,v 1.1 2011/08/28 10:49:07 hwoarang Exp $
+
+EAPI=2
+inherit qt4-r2
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="A Qt4 based animation and drawing program"
+HOMEPAGE="http://www.pencil-animation.org/"
+SRC_URI="mirror://sourceforge/pencil-planner/${MY_P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/qt-gui:4
+ >=media-libs/ming-0.4.3"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}-source
+
+src_prepare() {
+ sed -i s:SWFSprite:SWFMovieClip:g src/external/flash/flash.{cpp,h}
+}
+
+src_install() {
+ # install target not yet provided
+ #emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ newbin Pencil ${PN} || die "dobin failed"
+
+ dodoc README TODO || die
+
+ mv "${S}"/icons/icon.png "${S}"/icons/${PN}.png
+ doicon "${S}"/icons/${PN}.png || die "doicon failed"
+ make_desktop_entry ${PN} Pencil ${PN} Graphics
+}