summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-04 14:15:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-04 14:15:28 +0000
commit408e07f29058628631f8a51497100053a9b582c6 (patch)
tree917aa35350c9b027be47cc4607698dc3751280a1 /media-gfx/pixie
parentVersion bump, more small changes in prep for a final release (diff)
downloadgentoo-2-408e07f29058628631f8a51497100053a9b582c6.tar.gz
gentoo-2-408e07f29058628631f8a51497100053a9b582c6.tar.bz2
gentoo-2-408e07f29058628631f8a51497100053a9b582c6.zip
Fix further problems with the pixie ebuild, thanks to Mauro Toffanin in bug #299593.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/pixie')
-rw-r--r--media-gfx/pixie/ChangeLog11
-rw-r--r--media-gfx/pixie/pixie-2.2.6-r1.ebuild (renamed from media-gfx/pixie/pixie-2.2.6.ebuild)27
2 files changed, 29 insertions, 9 deletions
diff --git a/media-gfx/pixie/ChangeLog b/media-gfx/pixie/ChangeLog
index 547bec765b42..05d84e625289 100644
--- a/media-gfx/pixie/ChangeLog
+++ b/media-gfx/pixie/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/pixie
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pixie/ChangeLog,v 1.49 2009/12/28 20:58:08 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pixie/ChangeLog,v 1.50 2010/01/04 14:15:28 flameeyes Exp $
+
+*pixie-2.2.6-r1 (04 Jan 2010)
+
+ 04 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org> -pixie-2.2.6.ebuild,
+ +pixie-2.2.6-r1.ebuild:
+ Fix further problems with the pixie ebuild, thanks to Mauro Toffanin in
+ bug #299593.
*pixie-2.2.6 (28 Dec 2009)
diff --git a/media-gfx/pixie/pixie-2.2.6.ebuild b/media-gfx/pixie/pixie-2.2.6-r1.ebuild
index 54b30762170e..bbc0c4745d7d 100644
--- a/media-gfx/pixie/pixie-2.2.6.ebuild
+++ b/media-gfx/pixie/pixie-2.2.6-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pixie/pixie-2.2.6.ebuild,v 1.1 2009/12/28 20:58:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pixie/pixie-2.2.6-r1.ebuild,v 1.1 2010/01/04 14:15:28 flameeyes Exp $
EAPI="2"
inherit eutils multilib autotools
@@ -17,8 +17,7 @@ IUSE="X static-libs"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-RDEPEND="!mail-client/nmh
- media-libs/jpeg
+RDEPEND="media-libs/jpeg
media-libs/tiff
media-libs/libpng
x11-libs/fltk:1.1[opengl]
@@ -43,11 +42,20 @@ DEPEND="${RDEPEND}
src_prepare() {
# FIX: missing @includedir@
+ # https://sf.net/tracker/?func=detail&aid=2923415&group_id=59462&atid=491094
epatch "${FILESDIR}/${P}-autotools.patch"
eautoreconf
+
+ # FIX: removing pre-compiled shaders
+ # shaders must be removed before of their compilation or make
+ # parallelism can break the regeneration process, with resulting
+ # missing shaders.
+ rm "${S}"/shaders/*.sdr
}
src_configure() {
+ # NOTE: the option program-transform-name is used to avoid binary name
+ # conflict with package: mail-client/nmh (see #295996)
econf \
$(use_with X x) \
$(use_enable static-libs static) \
@@ -61,13 +69,15 @@ src_configure() {
--with-modulesdir=/usr/$(get_libdir)/pixie/modules \
--enable-openexr-threads \
--mandir=/usr/share/man \
- --bindir=/usr/bin
+ --bindir=/usr/bin \
+ --program-transform-name="s/show/pixie-show/"
}
src_compile() {
emake || die "emake failed"
- # regenerating Pixie shaders
+ # regenerating Pixie shaders - see upstream bug report:
+ # https://sf.net/tracker/?func=detail&aid=2923407&group_id=59462&atid=491094
einfo "Re-building Pixie Shaders for v${PV} format"
emake -f "${FILESDIR}/Makefile.shaders" -C "${S}/shaders"
}
@@ -75,8 +85,11 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "installation failed."
+ insinto /usr/share/Pixie/textures
+ doins "${S}"/textures/*
+
# remove useless .la files
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -delete || die "removal of libtool archive files failed"
dodoc README AUTHORS ChangeLog || die
}