summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-08 16:47:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-08 16:47:08 +0000
commitf73326646e0a5d432952db01a5a39e095a997e36 (patch)
treed50d08ad007efc5221a0db150366cc7bc629b512 /media-gfx/rawstudio
parentversion bump (diff)
downloadgentoo-2-f73326646e0a5d432952db01a5a39e095a997e36.tar.gz
gentoo-2-f73326646e0a5d432952db01a5a39e095a997e36.tar.bz2
gentoo-2-f73326646e0a5d432952db01a5a39e095a997e36.zip
Version bump wrt #362919 by Jens-Uwe Peter, Martijn van den Broek and Stefan Wimmer
(Portage version: 2.2.0_alpha63/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/rawstudio')
-rw-r--r--media-gfx/rawstudio/ChangeLog9
-rw-r--r--media-gfx/rawstudio/files/rawstudio-2.0-libpng15.patch35
-rw-r--r--media-gfx/rawstudio/rawstudio-2.0.ebuild54
3 files changed, 97 insertions, 1 deletions
diff --git a/media-gfx/rawstudio/ChangeLog b/media-gfx/rawstudio/ChangeLog
index db6bc2570ca1..a007f6caee72 100644
--- a/media-gfx/rawstudio/ChangeLog
+++ b/media-gfx/rawstudio/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/rawstudio
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawstudio/ChangeLog,v 1.22 2011/03/12 10:34:50 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawstudio/ChangeLog,v 1.23 2011/10/08 16:47:08 ssuominen Exp $
+
+*rawstudio-2.0 (08 Oct 2011)
+
+ 08 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> +rawstudio-2.0.ebuild,
+ +files/rawstudio-2.0-libpng15.patch:
+ Version bump wrt #362919 by Jens-Uwe Peter, Martijn van den Broek and Stefan
+ Wimmer
12 Mar 2011; Tim Harder <radhermit@gentoo.org> rawstudio-1.2.ebuild:
Use slot dep for gtk+.
diff --git a/media-gfx/rawstudio/files/rawstudio-2.0-libpng15.patch b/media-gfx/rawstudio/files/rawstudio-2.0-libpng15.patch
new file mode 100644
index 000000000000..c23a24f64034
--- /dev/null
+++ b/media-gfx/rawstudio/files/rawstudio-2.0-libpng15.patch
@@ -0,0 +1,35 @@
+--- plugins/output-pngfile/output-pngfile.c
++++ plugins/output-pngfile/output-pngfile.c
+@@ -23,6 +23,7 @@
+ #include <gettext.h>
+ #include "config.h"
+ #include <png.h>
++#include <zlib.h>
+
+ #define RS_TYPE_PNGFILE (rs_pngfile_type)
+ #define RS_PNGFILE(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), RS_TYPE_PNGFILE, RSPngfile))
+@@ -198,7 +199,7 @@
+ rs_icc_profile_get_data(profile, &data, &data_length);
+
+ // FIXME: Insert correct profile name
+- png_set_iCCP(png_ptr, info_ptr, "Profile name", PNG_COMPRESSION_TYPE_BASE, data, data_length);
++ png_set_iCCP(png_ptr, info_ptr, "Profile name", PNG_COMPRESSION_TYPE_BASE, (png_const_bytep)data, data_length);
+ if (pngfile->save16bit)
+ png_set_gAMA(png_ptr, info_ptr, 1.0);
+ }
+--- plugins/load-gdk/exiv2-colorspace.cpp
++++ plugins/load-gdk/exiv2-colorspace.cpp
+@@ -125,11 +125,11 @@
+
+ int compression_type;
+ /* Extract embedded ICC profile */
+- if (info_ptr->valid & PNG_INFO_iCCP)
++ if (png_get_valid(png_ptr, info_ptr, TRUE) & PNG_INFO_iCCP)
+ {
+ png_uint_32 retval = png_get_iCCP (png_ptr, info_ptr,
+ (png_charpp) &icc_profile_title, &compression_type,
+- (png_charpp) &icc_profile, (png_uint_32*) &icc_profile_size);
++ (png_byte**) &icc_profile, (png_uint_32*) &icc_profile_size);
+ if (retval != 0)
+ {
+ RSIccProfile *icc = rs_icc_profile_new_from_memory((gchar*)icc_profile, icc_profile_size, TRUE);
diff --git a/media-gfx/rawstudio/rawstudio-2.0.ebuild b/media-gfx/rawstudio/rawstudio-2.0.ebuild
new file mode 100644
index 000000000000..814b5eb41c47
--- /dev/null
+++ b/media-gfx/rawstudio/rawstudio-2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawstudio/rawstudio-2.0.ebuild,v 1.1 2011/10/08 16:47:08 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A program for reading and manipulating raw images from digital cameras"
+HOMEPAGE="http://rawstudio.org/"
+SRC_URI="http://${PN}.org/files/release/${P}.tar.gz"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/libxml2
+ >=dev-libs/openssl-1
+ >=gnome-base/gconf-2
+ media-libs/flickcurl
+ =media-libs/lcms-1*
+ media-libs/lensfun
+ media-libs/libgphoto2
+ media-libs/tiff
+ media-gfx/exiv2
+ net-misc/curl
+ sci-libs/fftw:3.0
+ sys-apps/dbus
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( AUTHORS NEWS README TODO )
+
+src_prepare() {
+ find . -name Makefile.am -exec sed -i -e 's:-O4:-Wall:' {} +
+ sed -i -e '/^icondir/s:icons:pixmaps:' pixmaps/Makefile.am || die
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}"usr -name '*.la' -exec rm -f {} +
+}