summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2010-09-01 21:21:56 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2010-09-01 21:21:56 +0000
commit42f0b8ba4df8c58ac042ad475281b26e3aa97cd5 (patch)
tree4bdb8777e30164e36e510ff8c1e428dbd009993e /media-gfx/sane-backends
parentclean up SRC_URI (diff)
downloadgentoo-2-42f0b8ba4df8c58ac042ad475281b26e3aa97cd5.tar.gz
gentoo-2-42f0b8ba4df8c58ac042ad475281b26e3aa97cd5.tar.bz2
gentoo-2-42f0b8ba4df8c58ac042ad475281b26e3aa97cd5.zip
Little fix for missing colors when using xerox_mfp, bug #332667.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'media-gfx/sane-backends')
-rw-r--r--media-gfx/sane-backends/ChangeLog6
-rw-r--r--media-gfx/sane-backends/files/xerox-grey.patch23
-rw-r--r--media-gfx/sane-backends/sane-backends-1.0.21-r1.ebuild3
3 files changed, 30 insertions, 2 deletions
diff --git a/media-gfx/sane-backends/ChangeLog b/media-gfx/sane-backends/ChangeLog
index df5526a29ed1..97b290b05fd7 100644
--- a/media-gfx/sane-backends/ChangeLog
+++ b/media-gfx/sane-backends/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/sane-backends
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.173 2010/09/01 20:56:24 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.174 2010/09/01 21:21:56 phosphan Exp $
+
+ 01 Sep 2010; Patrick Kursawe <phosphan@gentoo.org>
+ sane-backends-1.0.21-r1.ebuild, +files/xerox-grey.patch:
+ Little fix for missing colors when using xerox_mfp, bug #332667.
*sane-backends-1.0.21-r1 (01 Sep 2010)
diff --git a/media-gfx/sane-backends/files/xerox-grey.patch b/media-gfx/sane-backends/files/xerox-grey.patch
new file mode 100644
index 000000000000..d3637b12650d
--- /dev/null
+++ b/media-gfx/sane-backends/files/xerox-grey.patch
@@ -0,0 +1,23 @@
+diff --git a/backend/xerox_mfp.c b/backend/xerox_mfp.c
+index cda6e82..ab0f773 100644
+--- a/backend/xerox_mfp.c
++++ b/backend/xerox_mfp.c
+@@ -386,6 +386,7 @@ static int doc_source_to_code[] = {
+
+ static SANE_String_Const scan_modes[] = {
+ SANE_VALUE_SCAN_MODE_LINEART,
++ SANE_VALUE_SCAN_MODE_HALFTONE,
+ SANE_VALUE_SCAN_MODE_GRAY,
+ SANE_VALUE_SCAN_MODE_COLOR,
+ NULL
+@@ -940,8 +941,8 @@ SANE_Status
+ sane_init (SANE_Int * version_code, SANE_Auth_Callback cb)
+ {
+ DBG_INIT ();
+- DBG (2, "sane_init: Xerox backend (build %d) %p, %p\n", BACKEND_BUILD,
+- (void *)version_code, (void *)cb);
++ DBG (2, "sane_init: Xerox backend (build %d), version %s null, authorize %s null\n", BACKEND_BUILD,
++ (version_code) ? "!=" : "==", (cb) ? "!=" : "==");
+
+ if (version_code)
+ *version_code = SANE_VERSION_CODE (V_MAJOR, V_MINOR, BACKEND_BUILD);
diff --git a/media-gfx/sane-backends/sane-backends-1.0.21-r1.ebuild b/media-gfx/sane-backends/sane-backends-1.0.21-r1.ebuild
index 245031a4229b..7f0a2442dc73 100644
--- a/media-gfx/sane-backends/sane-backends-1.0.21-r1.ebuild
+++ b/media-gfx/sane-backends/sane-backends-1.0.21-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/sane-backends-1.0.21-r1.ebuild,v 1.1 2010/09/01 20:56:24 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/sane-backends-1.0.21-r1.ebuild,v 1.2 2010/09/01 21:21:56 phosphan Exp $
EAPI="1"
@@ -160,6 +160,7 @@ src_unpack() {
hpaio
EOF
epatch "${DISTDIR}/${P}-i18n.patch"
+ epatch "${FILESDIR}/xerox-grey.patch"
}
src_compile() {