summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-23 05:18:07 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-23 05:18:07 +0000
commit3a89607874133fbc78bdd1a8fa60f1c858d57fff (patch)
tree7e4ac1bb8a92559928b450b0d81b702ed188cba4 /media-gfx/sodipodi
parentadded SLOT/KEYWORDS (diff)
downloadgentoo-2-3a89607874133fbc78bdd1a8fa60f1c858d57fff.tar.gz
gentoo-2-3a89607874133fbc78bdd1a8fa60f1c858d57fff.tar.bz2
gentoo-2-3a89607874133fbc78bdd1a8fa60f1c858d57fff.zip
repoman'd
Diffstat (limited to 'media-gfx/sodipodi')
-rw-r--r--media-gfx/sodipodi/sodipodi-0.24.1-r4.ebuild40
1 files changed, 17 insertions, 23 deletions
diff --git a/media-gfx/sodipodi/sodipodi-0.24.1-r4.ebuild b/media-gfx/sodipodi/sodipodi-0.24.1-r4.ebuild
index f830312c4514..cb8972c56d02 100644
--- a/media-gfx/sodipodi/sodipodi-0.24.1-r4.ebuild
+++ b/media-gfx/sodipodi/sodipodi-0.24.1-r4.ebuild
@@ -1,16 +1,20 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sodipodi/sodipodi-0.24.1-r4.ebuild,v 1.3 2002/07/11 06:30:38 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sodipodi/sodipodi-0.24.1-r4.ebuild,v 1.4 2002/07/23 05:18:07 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Vector illustrating application for GNOME"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://sodipodi.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
RDEPEND=">=gnome-base/gnome-print-0.30
- >=gnome-extra/gal-0.13-r1
- media-libs/gdk-pixbuf
- bonobo? ( >=gnome-base/bonobo-1.0.9 )"
+ >=gnome-extra/gal-0.13-r1
+ media-libs/gdk-pixbuf
+ bonobo? ( >=gnome-base/bonobo-1.0.9 )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -26,29 +30,19 @@ src_unpack() {
src_compile() {
local myconf
- myconf=""
-
# Bonobo support doesn't seem to work.
- if [ "`use bonobo`" ] ; then
- myconf="$myconf --with-bonobo"
- else
- myconf="$myconf --without-bonobo"
- fi
+ use bonobo \
+ && myconf="${myconf} --with-bonobo" \
+ || myconf="${myconf} --without-bonobo"
- if [ -z "`use nls`" ] ; then
- myconf="$myconf --disable-nls"
- fi
+ use nls || myconf="${myconf} --disable-nls"
CFLAGS="${CFLAGS} `gnome-config --cflags gdk_pixbuf`"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --sysconfdir=/etc \
- --enable-gnome \
- --enable-gnome-print \
- ${myconf} || die
+ econf \
+ --enable-gnome \
+ --enable-gnome-print \
+ ${myconf} || die
emake || die
}