summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-03-12 13:05:10 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-03-12 13:05:10 +0000
commit249808e8b6dc612b6c90433b6b2f62d6115c8f0e (patch)
tree7c0225dc095d254ded9b96c408ab9cca4fe2e140 /media-gfx/tachyon
parentMake it build with new automake (diff)
downloadgentoo-2-249808e8b6dc612b6c90433b6b2f62d6115c8f0e.tar.gz
gentoo-2-249808e8b6dc612b6c90433b6b2f62d6115c8f0e.tar.bz2
gentoo-2-249808e8b6dc612b6c90433b6b2f62d6115c8f0e.zip
[media-gfx/tachyon] We now use EAPI4
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/tachyon')
-rw-r--r--media-gfx/tachyon/ChangeLog10
-rw-r--r--media-gfx/tachyon/tachyon-0.98.9-r2.ebuild (renamed from media-gfx/tachyon/tachyon-0.98.9-r1.ebuild)21
2 files changed, 14 insertions, 17 deletions
diff --git a/media-gfx/tachyon/ChangeLog b/media-gfx/tachyon/ChangeLog
index 8bb2a988bb14..e7fb2111b97e 100644
--- a/media-gfx/tachyon/ChangeLog
+++ b/media-gfx/tachyon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/tachyon
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/tachyon/ChangeLog,v 1.4 2010/11/08 18:45:47 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/tachyon/ChangeLog,v 1.5 2012/03/12 13:05:10 alexxy Exp $
+
+*tachyon-0.98.9-r2 (12 Mar 2012)
+
+ 12 Mar 2012; Alexey Shvetsov <alexxy@gentoo.org> -tachyon-0.98.9-r1.ebuild,
+ +tachyon-0.98.9-r2.ebuild:
+ We now use EAPI4
08 Nov 2010; Kacper Kowalik <xarthisius@gentoo.org>
-tachyon-0.98.9.ebuild, tachyon-0.98.9-r1.ebuild:
diff --git a/media-gfx/tachyon/tachyon-0.98.9-r1.ebuild b/media-gfx/tachyon/tachyon-0.98.9-r2.ebuild
index caf6326326a6..279f7ed4e437 100644
--- a/media-gfx/tachyon/tachyon-0.98.9-r1.ebuild
+++ b/media-gfx/tachyon/tachyon-0.98.9-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/tachyon/tachyon-0.98.9-r1.ebuild,v 1.2 2010/11/08 18:45:47 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/tachyon/tachyon-0.98.9-r2.ebuild,v 1.1 2012/03/12 13:05:10 alexxy Exp $
-EAPI="2"
+EAPI="4"
inherit eutils toolchain-funcs
@@ -23,11 +23,11 @@ DEPEND="${CDEPEND}
dev-util/pkgconfig"
RDEPEND="${CDEPEND}"
+REQUIRED_USE="^^ ( opengl mpi )"
+
S="${WORKDIR}/${PN}/unix"
# TODO: Test on alpha, ia64, ppc
-# TODO: MPI: Depend on lam or virtual ? Test MPI
-# TODO: Check for threads dependencies
# TODO: add other architectures
# TODO: X, Motif, MBOX, Open Media Framework, Spaceball I/O, MGF ?
@@ -37,9 +37,6 @@ pkg_setup() {
if use threads ; then
if use opengl ; then
TACHYON_MAKE_TARGET=linux-thr-ogl
- if use mpi ; then
- die "tachyon does not support MPI with OpenGL and threads"
- fi
elif use mpi ; then
TACHYON_MAKE_TARGET=linux-mpi-thr
else
@@ -48,17 +45,11 @@ pkg_setup() {
# TODO: Support for linux-athlon-thr ?
else
- if use opengl ; then
- # TODO: Support target: linux-lam-64-ogl
-
- die "OpenGL is only available with USE=threads!"
- elif use mpi ; then
+ if use mpi ; then
TACHYON_MAKE_TARGET=linux-mpi
else
TACHYON_MAKE_TARGET=linux
fi
-
- # TODO: Support for linux-p4, linux-athlon, linux-ps2 ?
fi
if [[ -z "${TACHYON_MAKE_TARGET}" ]]; then