summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-29 17:23:15 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-29 17:23:15 +0000
commit0175dce22f2075c6b121f99bb6ec1d7b889652c2 (patch)
treee091d190ef0a89ef7957baf588ab3a019eaa24f6 /media-gfx
parentSwitch to CPU_FLAGS_X86. (diff)
downloadgentoo-2-0175dce22f2075c6b121f99bb6ec1d7b889652c2.tar.gz
gentoo-2-0175dce22f2075c6b121f99bb6ec1d7b889652c2.tar.bz2
gentoo-2-0175dce22f2075c6b121f99bb6ec1d7b889652c2.zip
Convert to CPU_FLAGS_X86.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/pngquant/ChangeLog8
-rw-r--r--media-gfx/pngquant/pngquant-1.8.3.ebuild8
-rw-r--r--media-gfx/pngquant/pngquant-2.0.2.ebuild8
-rw-r--r--media-gfx/pngquant/pngquant-2.1.0.ebuild8
-rw-r--r--media-gfx/pngquant/pngquant-2.2.0.ebuild8
5 files changed, 22 insertions, 18 deletions
diff --git a/media-gfx/pngquant/ChangeLog b/media-gfx/pngquant/ChangeLog
index 469898a82eec..9e69632e8580 100644
--- a/media-gfx/pngquant/ChangeLog
+++ b/media-gfx/pngquant/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/pngquant
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/ChangeLog,v 1.7 2014/04/25 08:35:26 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/ChangeLog,v 1.8 2015/01/29 17:23:15 mgorny Exp $
+
+ 29 Jan 2015; Michał Górny <mgorny@gentoo.org> pngquant-1.8.3.ebuild,
+ pngquant-2.0.2.ebuild, pngquant-2.1.0.ebuild, pngquant-2.2.0.ebuild:
+ Convert to CPU_FLAGS_X86.
*pngquant-2.2.0 (25 Apr 2014)
diff --git a/media-gfx/pngquant/pngquant-1.8.3.ebuild b/media-gfx/pngquant/pngquant-1.8.3.ebuild
index dcf25387b8c6..9a2024b33263 100644
--- a/media-gfx/pngquant/pngquant-1.8.3.ebuild
+++ b/media-gfx/pngquant/pngquant-1.8.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/pngquant-1.8.3.ebuild,v 1.3 2013/04/08 14:49:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/pngquant-1.8.3.ebuild,v 1.4 2015/01/29 17:23:15 mgorny Exp $
EAPI=5
inherit eutils flag-o-matic toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="http://pngquant.org/${P}-src.tar.bz2"
LICENSE="HPND rwpng"
SLOT=0
KEYWORDS="~amd64 ~x86"
-IUSE="debug openmp sse2"
+IUSE="debug openmp cpu_flags_x86_sse2"
RDEPEND="media-libs/libpng:0=
sys-libs/zlib:="
@@ -31,7 +31,7 @@ src_prepare() {
src_compile() {
use debug || append-cflags -DNDEBUG
- use sse2 && append-cflags -DUSE_SSE=1
+ use cpu_flags_x86_sse2 && append-cflags -DUSE_SSE=1
local openmp
if use openmp && tc-has-openmp; then
diff --git a/media-gfx/pngquant/pngquant-2.0.2.ebuild b/media-gfx/pngquant/pngquant-2.0.2.ebuild
index 9beae10107a2..ca314330a317 100644
--- a/media-gfx/pngquant/pngquant-2.0.2.ebuild
+++ b/media-gfx/pngquant/pngquant-2.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/pngquant-2.0.2.ebuild,v 1.1 2014/01/19 07:33:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/pngquant-2.0.2.ebuild,v 1.2 2015/01/29 17:23:15 mgorny Exp $
EAPI=5
inherit eutils flag-o-matic toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="http://pngquant.org/${P}-src.tar.bz2"
LICENSE="HPND rwpng"
SLOT=0
KEYWORDS="~amd64 ~x86"
-IUSE="debug openmp sse2"
+IUSE="debug openmp cpu_flags_x86_sse2"
RDEPEND="media-libs/libpng:0=
sys-libs/zlib:="
@@ -29,7 +29,7 @@ src_prepare() {
src_compile() {
use debug || append-cflags -DNDEBUG
- use sse2 && append-cflags -DUSE_SSE=1
+ use cpu_flags_x86_sse2 && append-cflags -DUSE_SSE=1
local openmp
if use openmp && tc-has-openmp; then
diff --git a/media-gfx/pngquant/pngquant-2.1.0.ebuild b/media-gfx/pngquant/pngquant-2.1.0.ebuild
index 5543818f2211..dfb88a909298 100644
--- a/media-gfx/pngquant/pngquant-2.1.0.ebuild
+++ b/media-gfx/pngquant/pngquant-2.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/pngquant-2.1.0.ebuild,v 1.1 2014/03/15 11:42:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/pngquant-2.1.0.ebuild,v 1.2 2015/01/29 17:23:15 mgorny Exp $
EAPI=5
inherit flag-o-matic toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="http://pngquant.org/${P}-src.tar.bz2"
LICENSE="HPND rwpng"
SLOT=0
KEYWORDS="~amd64 ~x86"
-IUSE="debug openmp sse2"
+IUSE="debug openmp cpu_flags_x86_sse2"
RDEPEND="media-libs/libpng:0=
sys-libs/zlib:="
@@ -29,7 +29,7 @@ src_prepare() {
src_compile() {
use debug || append-cflags -DNDEBUG
- use sse2 && append-cflags -DUSE_SSE=1
+ use cpu_flags_x86_sse2 && append-cflags -DUSE_SSE=1
local openmp
if use openmp && tc-has-openmp; then
diff --git a/media-gfx/pngquant/pngquant-2.2.0.ebuild b/media-gfx/pngquant/pngquant-2.2.0.ebuild
index 572bc35bd6a8..e0a7a53a7479 100644
--- a/media-gfx/pngquant/pngquant-2.2.0.ebuild
+++ b/media-gfx/pngquant/pngquant-2.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/pngquant-2.2.0.ebuild,v 1.1 2014/04/25 08:35:26 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngquant/pngquant-2.2.0.ebuild,v 1.2 2015/01/29 17:23:15 mgorny Exp $
EAPI=5
inherit flag-o-matic toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="http://pngquant.org/${P}-src.tar.bz2"
LICENSE="HPND rwpng"
SLOT=0
KEYWORDS="~amd64 ~x86"
-IUSE="debug openmp sse2"
+IUSE="debug openmp cpu_flags_x86_sse2"
RDEPEND="media-libs/libpng:0=
sys-libs/zlib:="
@@ -29,7 +29,7 @@ src_prepare() {
src_compile() {
use debug || append-cflags -DNDEBUG
- use sse2 && append-cflags -DUSE_SSE=1
+ use cpu_flags_x86_sse2 && append-cflags -DUSE_SSE=1
local openmp
if use openmp && tc-has-openmp; then