summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-11 22:08:02 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-11 22:08:02 +0000
commit3c72e76924162fa7723ad063a84f02625be0cfb6 (patch)
treee2ee48f10c1b31b87a19ad9e6a3d6c6e45a5ad44 /media-gfx
parentUpgrade postinst message from einfo to elog. Bump EAPI to 4. (diff)
downloadgentoo-2-3c72e76924162fa7723ad063a84f02625be0cfb6.tar.gz
gentoo-2-3c72e76924162fa7723ad063a84f02625be0cfb6.tar.bz2
gentoo-2-3c72e76924162fa7723ad063a84f02625be0cfb6.zip
Version bump.
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/rawtherapee/ChangeLog7
-rw-r--r--media-gfx/rawtherapee/rawtherapee-4.0.5.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/media-gfx/rawtherapee/ChangeLog b/media-gfx/rawtherapee/ChangeLog
index 6ca3ce8015cc..6d007627c9f1 100644
--- a/media-gfx/rawtherapee/ChangeLog
+++ b/media-gfx/rawtherapee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/rawtherapee
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/ChangeLog,v 1.2 2011/10/28 20:26:31 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/ChangeLog,v 1.3 2011/11/11 22:08:02 radhermit Exp $
+
+*rawtherapee-4.0.5 (11 Nov 2011)
+
+ 11 Nov 2011; Tim Harder <radhermit@gentoo.org> +rawtherapee-4.0.5.ebuild:
+ Version bump.
28 Oct 2011; Tim Harder <radhermit@gentoo.org> rawtherapee-4.0.4.ebuild:
Use lcms slot dep and fix check for openmp support (thanks to ssuominen).
diff --git a/media-gfx/rawtherapee/rawtherapee-4.0.5.ebuild b/media-gfx/rawtherapee/rawtherapee-4.0.5.ebuild
new file mode 100644
index 000000000000..bcfdd2cd963e
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-4.0.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/rawtherapee-4.0.5.ebuild,v 1.1 2011/11/11 22:08:02 radhermit Exp $
+
+EAPI="4"
+
+inherit cmake-utils toolchain-funcs
+
+DESCRIPTION="Digital photo editing tool focused on RAW image file manipulation and conversion"
+HOMEPAGE="http://www.rawtherapee.com/"
+SRC_URI="http://dev.gentoo.org/~radhermit/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 doc openmp"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ >=dev-cpp/gtkmm-2.12:2.4
+ >=dev-cpp/glibmm-2.16:2
+ dev-libs/libsigc++:2
+ media-libs/tiff
+ media-libs/libpng
+ media-libs/libiptcdata
+ media-libs/lcms:2
+ sys-libs/zlib
+ virtual/jpeg"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.0.4-nohg.patch )
+
+pkg_setup() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+
+ mycmakeargs=(
+ $(cmake-utils_use openmp OPTION_OMP)
+ $(cmake-utils_use_with bzip2 BZIP)
+ -DCREDITSDIR=/usr/share/doc/${PF}
+ )
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc doc/built/pdf/en/RawTherapeeManual_4.0.pdf
+}