summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-08-10 22:52:46 +0000
committerMichael Januszewski <spock@gentoo.org>2006-08-10 22:52:46 +0000
commit4e8b3752c7be36f65044918b6c94cc850952f608 (patch)
tree65a9ba980a181a57761299a36dee123c4d8584d0 /media-gfx
parentmore masking due to sys-kernel/openmosix-sources mask (diff)
downloadgentoo-2-4e8b3752c7be36f65044918b6c94cc850952f608.tar.gz
gentoo-2-4e8b3752c7be36f65044918b6c94cc850952f608.tar.bz2
gentoo-2-4e8b3752c7be36f65044918b6c94cc850952f608.zip
Make sure splash_util.static is linked against nptl libs. Should fix bug #140511.
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/splashutils/ChangeLog7
-rw-r--r--media-gfx/splashutils/splashutils-1.3-r2.ebuild13
2 files changed, 18 insertions, 2 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 2a162c35f97a..09e8d2d6365c 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.63 2006/08/08 22:01:02 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.64 2006/08/10 22:52:46 spock Exp $
+
+ 10 Aug 2006; Michał Januszewski <spock@gentoo.org>
+ splashutils-1.3-r2.ebuild:
+ Make sure splash_util.static is linked against nptl libs. Should fix bug
+ #140511.
*splashutils-1.3-r2 (08 Aug 2006)
diff --git a/media-gfx/splashutils/splashutils-1.3-r2.ebuild b/media-gfx/splashutils/splashutils-1.3-r2.ebuild
index 3046a24f869a..dca526361d35 100644
--- a/media-gfx/splashutils/splashutils-1.3-r2.ebuild
+++ b/media-gfx/splashutils/splashutils-1.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.3-r2.ebuild,v 1.1 2006/08/08 22:01:02 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.3-r2.ebuild,v 1.2 2006/08/10 22:52:46 spock Exp $
inherit eutils multilib toolchain-funcs
@@ -67,6 +67,10 @@ src_unpack() {
epatch ${FILESDIR}/splashutils-1.3-r2.patch
+ # Make sure the static version of splash_util is linked against the nptl
+ # libraries and not the linuxthreads ones.
+ sed -i -e 's#$(LDLIBS) -static#$(LDLIBS) -L/usr/lib/nptl -static#' Makefile
+
# Check whether the kernel tree has been patched with fbsplash.
if [[ ! -e ${ROOT}/usr/$(get_libdir)/klibc/include/linux/console_splash.h ]]; then
ewarn "The kernel tree against which dev-libs/klibc was built was not patched"
@@ -74,6 +78,13 @@ src_unpack() {
ewarn "without fbsplash support (ie. verbose mode will not work)."
fi
+ if has_version sys-libs/glibc && ! built_with_use sys-libs/glibc nptl ; then
+ eerror "Your sys-libs/glibc has been built with support for linuxthreads only."
+ eerror "This package requires nptl to work correctly. Please recompile glibc"
+ eerror "with the 'nptl' USE flag enabled."
+ die "nptl not available"
+ fi
+
if built_with_use sys-devel/gcc vanilla ; then
ewarn "Your GCC was built with the 'vanilla' flag set. If you can't compile"
ewarn "splashutils, you're on your own, as this configuration is not supported."