summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-26 08:46:22 +0000
committerJustin Lecher <jlec@gentoo.org>2013-06-26 08:46:22 +0000
commit4f6fcd4330b776c1f06b3a3fb2b6441ac2d84846 (patch)
tree49f5d15cc5cb2d403db75d036d3c3db2b946a6d7 /media-gfx
parentx86 stable, see bug 474018 (diff)
downloadgentoo-2-4f6fcd4330b776c1f06b3a3fb2b6441ac2d84846.tar.gz
gentoo-2-4f6fcd4330b776c1f06b3a3fb2b6441ac2d84846.tar.bz2
gentoo-2-4f6fcd4330b776c1f06b3a3fb2b6441ac2d84846.zip
media-gfx/shotwell: Backport compatibility fix for libraw-0.15, #474708
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/shotwell/ChangeLog6
-rw-r--r--media-gfx/shotwell/files/shotwell-0.14.1-libraw.patch58
-rw-r--r--media-gfx/shotwell/shotwell-0.14.1.ebuild5
3 files changed, 66 insertions, 3 deletions
diff --git a/media-gfx/shotwell/ChangeLog b/media-gfx/shotwell/ChangeLog
index d69d9baec2a8..5ce12bcfa6fb 100644
--- a/media-gfx/shotwell/ChangeLog
+++ b/media-gfx/shotwell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/shotwell
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/ChangeLog,v 1.55 2013/05/08 06:37:02 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/ChangeLog,v 1.56 2013/06/26 08:46:22 jlec Exp $
+
+ 26 Jun 2013; Justin Lecher <jlec@gentoo.org> shotwell-0.14.1.ebuild,
+ +files/shotwell-0.14.1-libraw.patch:
+ Backport compatibility fix for libraw-0.15, #474708
08 May 2013; Justin Lecher <jlec@gentoo.org> shotwell-0.13.1-r2.ebuild,
shotwell-0.14.0-r1.ebuild, shotwell-0.14.1.ebuild:
diff --git a/media-gfx/shotwell/files/shotwell-0.14.1-libraw.patch b/media-gfx/shotwell/files/shotwell-0.14.1-libraw.patch
new file mode 100644
index 000000000000..de60afe6accd
--- /dev/null
+++ b/media-gfx/shotwell/files/shotwell-0.14.1-libraw.patch
@@ -0,0 +1,58 @@
+commit 89aa167726d12f9ae0b53c01a2fdc54601fc3cc5
+Author: Jim Nelson <jim@yorba.org>
+Date: Wed May 29 11:52:09 2013 -0700
+
+ Build with LibRaw 0.15: Closes #7012
+
+ LibRaw 0.15 removed document-mode processing, which, as their release
+ notes say, "no one uses". Compile error were nothing more than
+ missing symbols -- Shotwell wasn't using it either.
+
+diff --git a/src/photos/GRaw.vala b/src/photos/GRaw.vala
+index f57886e..b7c3922 100644
+--- a/src/photos/GRaw.vala
++++ b/src/photos/GRaw.vala
+@@ -21,12 +21,6 @@ public enum Colorspace {
+ XYZ = 5
+ }
+
+-public enum DocMode {
+- STANDARD = 0,
+- GRAYSCALE = 1,
+- GRAYSCALE_NO_WHITE_BALANCE = 2
+-}
+-
+ public errordomain Exception {
+ UNSPECIFIED,
+ UNSUPPORTED_FILE,
+@@ -167,10 +161,6 @@ public class Processor {
+ throw_exception("adjust_sizes_info_only", proc.adjust_sizes_info_only());
+ }
+
+- public void document_mode_processing() throws Exception {
+- throw_exception("document_mode_processing", proc.document_mode_processing());
+- }
+-
+ public unowned LibRaw.ImageOther get_image_other() {
+ return proc.get_image_other();
+ }
+@@ -244,7 +234,6 @@ public class Processor {
+ // threshold
+ output_params->half_size = half_size;
+ // four_color_rgb
+- output_params->document_mode = GRaw.DocMode.STANDARD;
+ output_params->highlight = GRaw.HighlightMode.CLIP;
+ output_params->use_auto_wb = true;
+ output_params->use_camera_wb = true;
+diff --git a/vapi/libraw.vapi b/vapi/libraw.vapi
+index 05de461..a8a0a4d 100644
+--- a/vapi/libraw.vapi
++++ b/vapi/libraw.vapi
+@@ -104,7 +104,6 @@ public struct OutputParams {
+ public float threshold;
+ public bool half_size;
+ public bool four_color_rgb;
+- public int document_mode;
+ public int highlight;
+ public bool use_auto_wb;
+ public bool use_camera_wb;
diff --git a/media-gfx/shotwell/shotwell-0.14.1.ebuild b/media-gfx/shotwell/shotwell-0.14.1.ebuild
index 2b4a0f133e29..9a839229ffd8 100644
--- a/media-gfx/shotwell/shotwell-0.14.1.ebuild
+++ b/media-gfx/shotwell/shotwell-0.14.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.14.1.ebuild,v 1.2 2013/05/08 06:37:02 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.14.1.ebuild,v 1.3 2013/06/26 08:46:22 jlec Exp $
EAPI=5
@@ -74,7 +74,8 @@ src_prepare() {
-e 's|CFLAGS :|CFLAGS +|g' \
-i plugins/Makefile.plugin.mk || die
epatch \
- "${FILESDIR}"/${PN}-0.13.1-ldflags.patch
+ "${FILESDIR}"/${PN}-0.13.1-ldflags.patch \
+ "${FILESDIR}"/${P}-libraw.patch
}
src_configure() {