summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-02-02 10:14:26 +0000
committerMarkus Meier <maekke@gentoo.org>2008-02-02 10:14:26 +0000
commit5daf2cdf14d548b668302353971bd3a4411f3382 (patch)
tree5918c48cf843288729fd7eb70eee19f95ed5eabf /media-gfx
parentremove depend.apache usage wrt #208033 (diff)
downloadgentoo-2-5daf2cdf14d548b668302353971bd3a4411f3382.tar.gz
gentoo-2-5daf2cdf14d548b668302353971bd3a4411f3382.tar.bz2
gentoo-2-5daf2cdf14d548b668302353971bd3a4411f3382.zip
old
(Portage version: 2.1.4)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/jhead/ChangeLog7
-rw-r--r--media-gfx/jhead/files/jhead-2.4-gcc4.diff138
-rw-r--r--media-gfx/jhead/files/jhead-2.5-gcc4.diff36
-rw-r--r--media-gfx/jhead/jhead-2.4.ebuild35
-rw-r--r--media-gfx/jhead/jhead-2.5.ebuild35
-rw-r--r--media-gfx/jhead/jhead-2.6.ebuild34
6 files changed, 6 insertions, 279 deletions
diff --git a/media-gfx/jhead/ChangeLog b/media-gfx/jhead/ChangeLog
index 07388b5d758a..93f8f206c867 100644
--- a/media-gfx/jhead/ChangeLog
+++ b/media-gfx/jhead/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/jhead
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.62 2008/01/27 16:03:45 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.63 2008/02/02 10:14:26 maekke Exp $
+
+ 02 Feb 2008; Markus Meier <maekke@gentoo.org> -files/jhead-2.4-gcc4.diff,
+ -files/jhead-2.5-gcc4.diff, -jhead-2.4.ebuild, -jhead-2.5.ebuild,
+ -jhead-2.6.ebuild:
+ old
27 Jan 2008; Christoph Mende <angelos@gentoo.org> jhead-2.7.ebuild:
Stable on amd64, bug #206182
diff --git a/media-gfx/jhead/files/jhead-2.4-gcc4.diff b/media-gfx/jhead/files/jhead-2.4-gcc4.diff
deleted file mode 100644
index ec8e18915424..000000000000
--- a/media-gfx/jhead/files/jhead-2.4-gcc4.diff
+++ /dev/null
@@ -1,138 +0,0 @@
-diff --exclude='*~' -Naur jhead-2.4.orig/exif.c jhead-2.4/exif.c
---- jhead-2.4.orig/exif.c 2005-09-10 15:38:49.000000000 -0300
-+++ jhead-2.4/exif.c 2005-09-10 15:51:45.000000000 -0300
-@@ -395,7 +395,7 @@
- unsigned char * ValuePtr;
- int ByteCount;
- char * DirEntry;
-- DirEntry = DIR_ENTRY_ADDR(DirStart, de);
-+ DirEntry = (char *)DIR_ENTRY_ADDR(DirStart, de);
-
- Tag = Get16u(DirEntry);
- Format = Get16u(DirEntry+2);
-@@ -421,7 +421,7 @@
- ValuePtr = OffsetBase+OffsetVal;
- }else{
- // 4 bytes or less and value is in the dir entry itself
-- ValuePtr = DirEntry+8;
-+ ValuePtr = (uchar *)DirEntry+8;
- }
-
- if (LastExifRefd < ValuePtr+ByteCount){
-@@ -493,17 +493,17 @@
- switch(Tag){
-
- case TAG_MAKE:
-- strncpy(ImageInfo.CameraMake, ValuePtr, 31);
-+ strncpy(ImageInfo.CameraMake, (char *)ValuePtr, 31);
- break;
-
- case TAG_MODEL:
-- strncpy(ImageInfo.CameraModel, ValuePtr, 39);
-+ strncpy(ImageInfo.CameraModel, (char *)ValuePtr, 39);
- break;
-
-
- case TAG_DATETIME_ORIGINAL:
- // If we get a DATETIME_ORIGINAL, we use that one.
-- strncpy(ImageInfo.DateTime, ValuePtr, 19);
-+ strncpy(ImageInfo.DateTime, (char *)ValuePtr, 19);
- // Fallthru...
-
- case TAG_DATETIME_DIGITIZED:
-@@ -511,14 +511,14 @@
- if (!isdigit(ImageInfo.DateTime[0])){
- // If we don't already have a DATETIME_ORIGINAL, use whatever
- // time fields we may have.
-- strncpy(ImageInfo.DateTime, ValuePtr, 19);
-+ strncpy(ImageInfo.DateTime, (char *)ValuePtr, 19);
- }
-
- if (ImageInfo.numDateTimeTags >= MAX_DATE_COPIES){
- ErrNonfatal("More than %d date fields! This is nuts", MAX_DATE_COPIES, 0);
- break;
- }
-- ImageInfo.DateTimePointers[ImageInfo.numDateTimeTags++] = ValuePtr;
-+ ImageInfo.DateTimePointers[ImageInfo.numDateTimeTags++] = (char *)ValuePtr;
- break;
-
-
-@@ -540,13 +540,13 @@
- int c;
- c = (ValuePtr)[a];
- if (c != '\0' && c != ' '){
-- strncpy(ImageInfo.Comments, a+ValuePtr, 199);
-+ strncpy(ImageInfo.Comments, (char *)(a+ValuePtr), 199);
- break;
- }
- }
-
- }else{
-- strncpy(ImageInfo.Comments, ValuePtr, 199);
-+ strncpy(ImageInfo.Comments, (char *)ValuePtr, 199);
- }
- break;
-
-@@ -927,7 +927,7 @@
- for (de=0;de<NumDirEntries;de++){
- int Tag;
- char * DirEntry;
-- DirEntry = DIR_ENTRY_ADDR(DirWithThumbnailPtrs, de);
-+ DirEntry = (char *)DIR_ENTRY_ADDR(DirWithThumbnailPtrs, de);
- Tag = Get16u(DirEntry);
- if (Tag == TAG_THUMBNAIL_OFFSET || Tag == TAG_THUMBNAIL_LENGTH){
- // We remove data out of the exif directory by doing a memmove on the rest
-diff --exclude='*~' -Naur jhead-2.4.orig/gpsinfo.c jhead-2.4/gpsinfo.c
---- jhead-2.4.orig/gpsinfo.c 2005-09-10 15:38:49.000000000 -0300
-+++ jhead-2.4/gpsinfo.c 2005-09-10 15:48:24.000000000 -0300
-@@ -84,7 +84,7 @@
- int ComponentSize;
- unsigned ByteCount;
- char * DirEntry;
-- DirEntry = DIR_ENTRY_ADDR(DirStart, de);
-+ DirEntry = (char *)DIR_ENTRY_ADDR(DirStart, de);
-
- Tag = Get16u(DirEntry);
- Format = Get16u(DirEntry+2);
-@@ -111,7 +111,7 @@
- ValuePtr = OffsetBase+OffsetVal;
- }else{
- // 4 bytes or less and value is in the dir entry itself
-- ValuePtr = DirEntry+8;
-+ ValuePtr = (uchar *)DirEntry+8;
- }
-
- switch(Tag){
-diff --exclude='*~' -Naur jhead-2.4.orig/jpgfile.c jhead-2.4/jpgfile.c
---- jhead-2.4.orig/jpgfile.c 2005-09-10 15:38:49.000000000 -0300
-+++ jhead-2.4/jpgfile.c 2005-09-10 15:41:41.000000000 -0300
-@@ -245,7 +245,7 @@
- // that uses marker 31 for non exif stuff. Thus make sure
- // it says 'Exif' in the section before treating it as exif.
- if ((ReadMode & READ_EXIF) && memcmp(Data+2, "Exif", 4) == 0){
-- process_EXIF((char *)Data, itemlen);
-+ process_EXIF(Data, itemlen);
- }else{
- // Discard this section.
- free(Sections[--SectionsRead].Data);
-diff --exclude='*~' -Naur jhead-2.4.orig/makernote.c jhead-2.4/makernote.c
---- jhead-2.4.orig/makernote.c 2005-09-10 15:38:49.000000000 -0300
-+++ jhead-2.4/makernote.c 2005-09-10 15:49:28.000000000 -0300
-@@ -48,7 +48,7 @@
- unsigned char * ValuePtr;
- int ByteCount;
- char * DirEntry;
-- DirEntry = DIR_ENTRY_ADDR(DirStart, de);
-+ DirEntry = (char *)DIR_ENTRY_ADDR(DirStart, de);
-
- Tag = Get16u(DirEntry);
- Format = Get16u(DirEntry+2);
-@@ -74,7 +74,7 @@
- ValuePtr = OffsetBase+OffsetVal;
- }else{
- // 4 bytes or less and value is in the dir entry itself
-- ValuePtr = DirEntry+8;
-+ ValuePtr = (uchar *)DirEntry+8;
- }
-
- if (ShowTags){
diff --git a/media-gfx/jhead/files/jhead-2.5-gcc4.diff b/media-gfx/jhead/files/jhead-2.5-gcc4.diff
deleted file mode 100644
index 1ee3aec3b797..000000000000
--- a/media-gfx/jhead/files/jhead-2.5-gcc4.diff
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naur jhead-2.5.orig/exif.c jhead-2.5/exif.c
---- jhead-2.5.orig/exif.c 2006-01-11 22:55:20.000000000 +0100
-+++ jhead-2.5/exif.c 2006-01-11 22:59:36.000000000 +0100
-@@ -329,7 +329,7 @@
- ByteCount -= s;
- if (ByteCount <= 0) break;
- printf(", ");
-- ((char *)ValuePtr) += s;
-+ ValuePtr = (char *)ValuePtr + s;
- }
- if (n >= 16) printf("...");
- }
-diff -Naur jhead-2.5.orig/jhead.c jhead-2.5/jhead.c
---- jhead-2.5.orig/jhead.c 2006-01-11 22:55:20.000000000 +0100
-+++ jhead-2.5/jhead.c 2006-01-11 22:58:51.000000000 +0100
-@@ -932,7 +932,7 @@
-
- for (a = 0; a < ImageInfo.numDateTimeTags; a++) {
- char * Pointer;
-- Pointer = ExifSection->Data+ImageInfo.DateTimeOffsets[a]+8;
-+ Pointer = (char *)ExifSection->Data+ImageInfo.DateTimeOffsets[a]+8;
- memcpy(Pointer, TempBuf, 19);
- }
-
-diff -Naur jhead-2.5.orig/jpgfile.c jhead-2.5/jpgfile.c
---- jhead-2.5.orig/jpgfile.c 2006-01-11 22:55:20.000000000 +0100
-+++ jhead-2.5/jpgfile.c 2006-01-11 22:58:07.000000000 +0100
-@@ -346,7 +346,7 @@
- char * ThumbnailPointer;
- Section_t * ExifSection;
- ExifSection = FindSection(M_EXIF);
-- ThumbnailPointer = ExifSection->Data+ImageInfo.ThumbnailOffset+8;
-+ ThumbnailPointer = (char *)ExifSection->Data+ImageInfo.ThumbnailOffset+8;
-
- fwrite(ThumbnailPointer, ImageInfo.ThumbnailSize ,1, ThumbnailFile);
- fclose(ThumbnailFile);
diff --git a/media-gfx/jhead/jhead-2.4.ebuild b/media-gfx/jhead/jhead-2.4.ebuild
deleted file mode 100644
index fb8739476537..000000000000
--- a/media-gfx/jhead/jhead-2.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.4.ebuild,v 1.11 2008/01/15 18:15:51 grobian Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
-HOMEPAGE="http://www.sentex.net/~mwandel/jhead/"
-SRC_URI="http://www.sentex.net/~mwandel/jhead/${P}.tar.gz"
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ~ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-DEPEND="virtual/libc"
-RDEPEND="virtual/libc
- media-libs/jpeg"
-
-src_unpack() {
- unpack ${A}; cd ${S}
- epatch "${FILESDIR}"/${P}-gcc4.diff
- sed -i "s:-O3 -Wall:${CFLAGS}:" makefile || die
-}
-
-src_compile() {
- export CC="$(tc-getCC)"
- emake || die
-}
-
-src_install() {
- dobin jhead || die
- dodoc {readme,changes}.txt
- dohtml usage.html
- doman jhead.1.gz
-}
diff --git a/media-gfx/jhead/jhead-2.5.ebuild b/media-gfx/jhead/jhead-2.5.ebuild
deleted file mode 100644
index bf0b426bc44e..000000000000
--- a/media-gfx/jhead/jhead-2.5.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.5.ebuild,v 1.11 2008/01/15 18:15:51 grobian Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
-HOMEPAGE="http://www.sentex.net/~mwandel/jhead/"
-SRC_URI="http://www.sentex.net/~mwandel/jhead/${P}.tar.gz"
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-DEPEND="virtual/libc"
-RDEPEND="virtual/libc
- media-libs/jpeg"
-
-src_unpack() {
- unpack ${A}; cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.5-gcc4.diff
- sed -i "s:-O3 -Wall:${CFLAGS}:" makefile || die "sed failed"
-}
-
-src_compile() {
- export CC="$(tc-getCC)"
- emake || die
-}
-
-src_install() {
- dobin jhead || die
- dodoc {readme,changes}.txt
- dohtml usage.html
- doman jhead.1.gz
-}
diff --git a/media-gfx/jhead/jhead-2.6.ebuild b/media-gfx/jhead/jhead-2.6.ebuild
deleted file mode 100644
index 645fb41d76ba..000000000000
--- a/media-gfx/jhead/jhead-2.6.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.6.ebuild,v 1.6 2008/01/15 18:15:51 grobian Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
-HOMEPAGE="http://www.sentex.net/~mwandel/jhead/"
-SRC_URI="http://www.sentex.net/~mwandel/jhead/${P}.tar.gz"
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 hppa ~ia64 ppc ~ppc64 sparc x86"
-IUSE=""
-
-DEPEND="virtual/libc"
-RDEPEND="virtual/libc
- media-libs/jpeg"
-
-src_unpack() {
- unpack ${A}; cd "${S}"
- sed -i "s:-O3 -Wall:${CFLAGS}:" makefile || die "sed failed"
-}
-
-src_compile() {
- export CC="$(tc-getCC)"
- emake || die
-}
-
-src_install() {
- dobin jhead || die
- dodoc {readme,changes}.txt
- dohtml usage.html
- doman jhead.1.gz
-}