summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-06 18:47:53 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-06 18:47:53 +0000
commit603c3a7c741f762a48e797f931338ca74c59f92d (patch)
tree81307feb3952f79e26dc2cc6f077c523beca6a36 /media-gfx
parentVersion bump. (diff)
downloadgentoo-2-603c3a7c741f762a48e797f931338ca74c59f92d.tar.gz
gentoo-2-603c3a7c741f762a48e797f931338ca74c59f92d.tar.bz2
gentoo-2-603c3a7c741f762a48e797f931338ca74c59f92d.zip
Fix #134834 properly by forcing LC_ALL instead of LC_COLLATE.
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphviz/ChangeLog5
-rw-r--r--media-gfx/graphviz/graphviz-2.8-r2.ebuild25
2 files changed, 14 insertions, 16 deletions
diff --git a/media-gfx/graphviz/ChangeLog b/media-gfx/graphviz/ChangeLog
index 7a7d867ece48..81cb1106835a 100644
--- a/media-gfx/graphviz/ChangeLog
+++ b/media-gfx/graphviz/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/graphviz
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.93 2006/09/25 12:18:48 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.94 2006/10/06 18:47:53 vapier Exp $
+
+ 06 Oct 2006; Mike Frysinger <vapier@gentoo.org> graphviz-2.8-r2.ebuild:
+ Fix #134834 properly by forcing LC_ALL instead of LC_COLLATE.
25 Sep 2006; Luca Barbato <lu_zero@gentoo.org> graphviz-2.8-r2.ebuild:
dont depend on swig if you arent building bindings
diff --git a/media-gfx/graphviz/graphviz-2.8-r2.ebuild b/media-gfx/graphviz/graphviz-2.8-r2.ebuild
index 0ca863d8baab..83ac3ae84811 100644
--- a/media-gfx/graphviz/graphviz-2.8-r2.ebuild
+++ b/media-gfx/graphviz/graphviz-2.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.8-r2.ebuild,v 1.3 2006/09/26 17:32:18 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.8-r2.ebuild,v 1.4 2006/10/06 18:47:53 vapier Exp $
WANT_AUTOCONF=latest
WANT_AUTOMAKE=latest
@@ -34,10 +34,7 @@ RDEPEND=">=sys-libs/zlib-1.1.3
php? ( dev-lang/php )
python? ( dev-lang/python )
ruby? ( dev-lang/ruby )
- X? ( || (
- ( x11-libs/libXaw x11-libs/libXpm )
- virtual/x11 )
- )
+ X? ( x11-libs/libXaw x11-libs/libXpm )
sys-devel/libtool"
DEPEND="${RDEPEND}
@@ -50,15 +47,13 @@ DEPEND="${RDEPEND}
lua? ( dev-lang/swig )
php? ( dev-lang/swig )
python? ( dev-lang/swig )
- ruby? ( dev-lang/swig )
- "
+ ruby? ( dev-lang/swig )"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch ${FILESDIR}/${P}-notcl.patch || die "epatch failed"
-
- elibtoolize
+ epatch "${FILESDIR}"/${P}-notcl.patch
+ sed -i 's:LC_COLLATE=C:LC_ALL=C:g' lib/common/Makefile.* #134834
eautoreconf
}
@@ -78,9 +73,9 @@ src_compile() {
$(use_enable python) \
$(use_enable ruby) \
--disable-{sharp,io} \
- $(use_with X x) || die "Configure Failed!"
-
- LC_ALL=C emake || die "Compile Failed!"
+ $(use_with X x) \
+ || die "Configure Failed!"
+ emake || die "Compile Failed!"
}
src_install() {
@@ -93,8 +88,8 @@ src_install() {
pkgconfigdir=/usr/$(get_libdir)/pkgconfig \
install || die "Install Failed!"
if use minimal ; then
- rm -rf "${D}"usr/share/doc/${PF}/{pdf,html}
- rm -rf "${D}"usr/$(get_libdir)/${PN}/{tcl,lua,perl,python,ruby}
+ rm -rf "${D}"/usr/share/doc/${PF}/{pdf,html}
+ rm -rf "${D}"/usr/$(get_libdir)/${PN}/{tcl,lua,perl,python,ruby}
fi
dodoc AUTHORS ChangeLog NEWS README
}