summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-13 01:16:10 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-13 01:16:10 +0000
commit6676aa4c57a55042a1db8dad43025375f5d2685a (patch)
tree525dd217ba0c9149874980cca2d21c9309f9eda4 /media-gfx
parentogg and vorbis flags are actually one oggvorbis flag (diff)
downloadgentoo-2-6676aa4c57a55042a1db8dad43025375f5d2685a.tar.gz
gentoo-2-6676aa4c57a55042a1db8dad43025375f5d2685a.tar.bz2
gentoo-2-6676aa4c57a55042a1db8dad43025375f5d2685a.zip
Compile against newer libpng
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gnuplot/files/digest-gnuplot-3.7.1-r31
-rw-r--r--media-gfx/gnuplot/gnuplot-3.7.1-r3.ebuild86
-rw-r--r--media-gfx/xfig/files/digest-xfig-3.2.3d-r11
-rw-r--r--media-gfx/xfig/xfig-3.2.3d-r1.ebuild41
4 files changed, 129 insertions, 0 deletions
diff --git a/media-gfx/gnuplot/files/digest-gnuplot-3.7.1-r3 b/media-gfx/gnuplot/files/digest-gnuplot-3.7.1-r3
new file mode 100644
index 000000000000..b393482c3a52
--- /dev/null
+++ b/media-gfx/gnuplot/files/digest-gnuplot-3.7.1-r3
@@ -0,0 +1 @@
+MD5 30798b4c14ea734969a86ee41a9c1dca gnuplot-3.7.1.tar.gz 1319233
diff --git a/media-gfx/gnuplot/gnuplot-3.7.1-r3.ebuild b/media-gfx/gnuplot/gnuplot-3.7.1-r3.ebuild
new file mode 100644
index 000000000000..59bc0bc91f29
--- /dev/null
+++ b/media-gfx/gnuplot/gnuplot-3.7.1-r3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/gnuplot-3.7.1-r3.ebuild,v 1.1 2002/04/13 01:11:20 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Quick and useful plotting program"
+SRC_URI="ftp://ftp.gnuplot.org/pub/gnuplot/${P}.tar.gz"
+HOMEPAGE="http://www.gnuplot.org"
+
+DEPEND="media-libs/libpng
+ plotutils? ( media-libs/plotutils )
+ readline? ( sys-libs/readline )
+ X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )"
+
+src_compile() {
+ local myvar
+ #--with-lasergnu flag seems to be broken and I'm too lazy to fix now
+ #myvar=" --with-png --without-gd --with-lasergnu"
+ myvar=" --with-png --without-gd --with-plot=/usr/lib"
+ #--with-plot enables the Gnu plotutils library
+ #need to specify path to differentiate from Unix plot
+ if [ -z "`use plotutils`" ]
+ then
+ myvar="${myvar} --without-plot"
+ else
+ myvar="${myvar} --with-plot=/usr/lib"
+ fi
+ if [ -z "`use X`" ]
+ then
+ myvar="${myvar} --without-x"
+ else
+ myvar="${myvar} --with-x"
+ fi
+ if [ -z "`use readline`" ]
+ then
+ #use the built-in readline
+ myvar="${myvar} --with-readline"
+ else
+ #use gnu readline
+ myvar="${myvar} --with-readline=gnu"
+ fi
+ if [ -z "`use svga`" ]
+ then
+ myvar="${myvar} --without-linux-vga"
+ else
+ myvar="${myvar} --with-linux-vga"
+ fi
+ ./configure \
+ ${myvar} \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share/gnuplot \
+ --mandir=/usr/share/man || die
+ mv Makefile Makefile.orig
+ sed -e 's/datadir = \/usr/datadir = ${prefix}/' \
+ -e 's/mandir = \/usr/mandir = ${prefix}/' \
+ Makefile.orig > Makefile
+ cd docs
+ mv Makefile Makefile.orig
+ sed -e 's/datadir = \/usr/datadir = ${prefix}/' Makefile.orig > Makefile
+ cd ..
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+}
+
+pkg_postinst() {
+ if [ "`use svga`" ]
+ then
+ einfo ""
+ einfo "*****************************************************************"
+ einfo " In order to enable ordinary users to use SVGA console graphics"
+ einfo " gnuplot needs to be set up as setuid root. Please note that"
+ einfo " this is usually considered to be a security hazard."
+ einfo " As root, manually chmod u+s /usr/bin/gnuplot"
+ einfo "*****************************************************************"
+ einfo
+ fi
+}
+
+
diff --git a/media-gfx/xfig/files/digest-xfig-3.2.3d-r1 b/media-gfx/xfig/files/digest-xfig-3.2.3d-r1
new file mode 100644
index 000000000000..a8f283652ca8
--- /dev/null
+++ b/media-gfx/xfig/files/digest-xfig-3.2.3d-r1
@@ -0,0 +1 @@
+MD5 c6321efc1e2796e111b250c58de2f2e0 xfig.3.2.3d.full.tar.gz 2846844
diff --git a/media-gfx/xfig/xfig-3.2.3d-r1.ebuild b/media-gfx/xfig/xfig-3.2.3d-r1.ebuild
new file mode 100644
index 000000000000..f2d51ea8bf88
--- /dev/null
+++ b/media-gfx/xfig/xfig-3.2.3d-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Michael Conrad Tilstra <tadpol@gentoo.org> <tadpol@tadpol.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xfig/xfig-3.2.3d-r1.ebuild,v 1.1 2002/04/13 01:11:56 seemant Exp $
+
+MY_P=${P/xfig-/xfig.}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION=""
+SRC_URI="http://www.xfig.org/xfigdist/${MY_P}.full.tar.gz"
+HOMEPAGE="http://www.xfig.org"
+
+DEPEND="virtual/x11
+ media-libs/jpeg
+ media-libs/libpng"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}.patch
+}
+
+src_compile() {
+ xmkmf || die
+ make || die
+}
+
+src_install () {
+ #Now install it.
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ make \
+ DESTDIR=${D} \
+ MANDIR=/usr/share/man/man1 \
+ MANSUFFIX=1 \
+ install.all || die
+
+ #Install docs
+ dodoc README FIGAPPS CHANGES LATEX.AND.XFIG
+}