summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-23 11:39:30 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-23 11:39:30 +0000
commita33b7afba7c8e2f751acff6c8de977b9349dfe02 (patch)
tree64784ae4b1d6412639f0c8bfdabda7bf81b46662 /media-gfx
parentsci-visualization/grace: Version BUmp, #452338 (diff)
downloadgentoo-2-a33b7afba7c8e2f751acff6c8de977b9349dfe02.tar.gz
gentoo-2-a33b7afba7c8e2f751acff6c8de977b9349dfe02.tar.bz2
gentoo-2-a33b7afba7c8e2f751acff6c8de977b9349dfe02.zip
media-gfx/ipe: Version BUmp, #452334
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/ipe/ChangeLog10
-rw-r--r--media-gfx/ipe/files/ipe-7.1.3-gold.patch30
-rw-r--r--media-gfx/ipe/ipe-7.1.3.ebuild81
-rw-r--r--media-gfx/ipe/metadata.xml4
4 files changed, 121 insertions, 4 deletions
diff --git a/media-gfx/ipe/ChangeLog b/media-gfx/ipe/ChangeLog
index 765ea8fc1e74..5f25aefd6278 100644
--- a/media-gfx/ipe/ChangeLog
+++ b/media-gfx/ipe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/ipe
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/ipe/ChangeLog,v 1.1 2012/05/10 17:05:59 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/ipe/ChangeLog,v 1.2 2013/01/23 11:39:30 jlec Exp $
+
+*ipe-7.1.3 (23 Jan 2013)
+
+ 23 Jan 2013; Justin Lecher <jlec@gentoo.org> +ipe-7.1.3.ebuild,
+ +files/ipe-7.1.3-gold.patch, metadata.xml:
+ Version BUmp, #452334
*ipe-7.1.2 (10 May 2012)
diff --git a/media-gfx/ipe/files/ipe-7.1.3-gold.patch b/media-gfx/ipe/files/ipe-7.1.3-gold.patch
new file mode 100644
index 000000000000..a28fafa15c43
--- /dev/null
+++ b/media-gfx/ipe/files/ipe-7.1.3-gold.patch
@@ -0,0 +1,30 @@
+ src/ipe/Makefile | 2 +-
+ src/ipescript/Makefile | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/ipe/Makefile b/src/ipe/Makefile
+index 21ac500..5a7a1ad 100644
+--- a/src/ipe/Makefile
++++ b/src/ipe/Makefile
+@@ -10,7 +10,7 @@ TARGET = $(call exe_target,ipe)
+ CPPFLAGS += -I../include -I../ipecanvas -I../ipecairo -I../ipelua \
+ $(LUA_CFLAGS) $(UI_CFLAGS) $(CAIRO_CFLAGS) $(ZLIB_CFLAGS)
+ LIBS += -L$(buildlib) -lipecanvas -lipecairo -lipelua -lipe -lipeui \
+- $(LUA_LIBS) $(UI_LIBS) $(CAIRO_LIBS) $(ZLIB_LIBS)
++ $(LUA_LIBS) $(UI_LIBS) $(CAIRO_LIBS) $(ZLIB_LIBS) -ldl
+
+ CPPFLAGS += -DIPELETDIR=\"$(IPELETDIR)\"
+ CPPFLAGS += -DIPELUADIR=\"$(IPELUADIR)\"
+diff --git a/src/ipescript/Makefile b/src/ipescript/Makefile
+index ff35fd9..2315f1f 100644
+--- a/src/ipescript/Makefile
++++ b/src/ipescript/Makefile
+@@ -8,7 +8,7 @@ include ../common.mak
+ TARGET = $(call exe_target,ipescript)
+
+ CPPFLAGS += -I../include -I../ipelua $(LUA_CFLAGS)
+-LIBS += -L$(buildlib) -lipelua -lipe $(LUA_LIBS)
++LIBS += -L$(buildlib) -lipelua -lipe $(LUA_LIBS) -ldl
+
+ CPPFLAGS += -DIPELETDIR=\"$(IPELETDIR)\"
+ CPPFLAGS += -DIPESTYLEDIR=\"$(IPESTYLEDIR)\"
diff --git a/media-gfx/ipe/ipe-7.1.3.ebuild b/media-gfx/ipe/ipe-7.1.3.ebuild
new file mode 100644
index 000000000000..0e0c65698b10
--- /dev/null
+++ b/media-gfx/ipe/ipe-7.1.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/ipe/ipe-7.1.3.ebuild,v 1.1 2013/01/23 11:39:30 jlec Exp $
+
+EAPI=5
+
+inherit eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="Drawing editor for creating figures in PDF or PS formats"
+HOMEPAGE="http://ipe7.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ipe7/${PN}/7.1.0/${P}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/texlive-core
+ dev-lang/lua
+ media-libs/freetype:2
+ x11-libs/cairo
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${P}/src"
+
+search_urw_fonts() {
+ # colon-separated list of paths
+ local texmfdist="$(kpsewhich -var-value=TEXMFDIST)"
+ # according to TeX directory structure
+ local urwdir=fonts/type1/urw
+ # add colon as field separator
+ local IFS="${IFS}:" dir
+ for dir in ${texmfdist}; do
+ if [[ -d ${dir}/${urwdir} ]]; then
+ URWFONTDIR="${dir}/${urwdir}"
+ return 0
+ fi
+ done
+ return 1
+}
+
+pkg_setup() {
+ if search_urw_fonts; then
+ einfo "URW fonts found in ${URWFONTDIR}"
+ else
+ ewarn "Could not find directory containing URW fonts"
+ ewarn "Ipe will not function properly without them."
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e 's/fpic/fPIC/' \
+ -e 's/moc-qt4/moc/' \
+ -e "s:\$(IPEPREFIX)/lib:\$(IPEPREFIX)/$(get_libdir):g" \
+ config.mak || die
+ sed -i -e 's/install -s/install/' common.mak || die
+
+ epatch "${FILESDIR}"/${P}-gold.patch
+}
+
+src_compile() {
+ emake \
+ CXX=$(tc-getCXX) \
+ IPEPREFIX="${EPREFIX}/usr" \
+ IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ emake install \
+ IPEPREFIX="${EPREFIX}/usr" \
+ IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html" \
+ INSTALL_ROOT="${ED}"
+ dodoc ../{news,readme}.txt
+ doicon ipe/icons/ipe.png
+ make_desktop_entry ipe Ipe ipe
+}
diff --git a/media-gfx/ipe/metadata.xml b/media-gfx/ipe/metadata.xml
index 4d721d0fca26..0fefe2a81889 100644
--- a/media-gfx/ipe/metadata.xml
+++ b/media-gfx/ipe/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang='en'>
+ <herd>sci</herd>
+ <longdescription lang="en">
Ipe is a drawing editor for creating figures in PDF or
(encapsulated) Postscript format. Ipe supports making small figures
for inclusion into LaTeX documents as well as making multi-page PDF