summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-06-22 09:40:13 +0000
committerPacho Ramos <pacho@gentoo.org>2014-06-22 09:40:13 +0000
commitce763870541e8f00ae89665be65b729120a7b963 (patch)
tree4167d260e97b9d6150aab463ed83a5cf2e006116 /media-gfx
parentDisable static library build, reported by galtgendo. (diff)
downloadgentoo-2-ce763870541e8f00ae89665be65b729120a7b963.tar.gz
gentoo-2-ce763870541e8f00ae89665be65b729120a7b963.tar.bz2
gentoo-2-ce763870541e8f00ae89665be65b729120a7b963.zip
Fix building due DEPRECATED warnings (#514050)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/DFBPoint/ChangeLog7
-rw-r--r--media-gfx/DFBPoint/DFBPoint-0.7.2.ebuild29
2 files changed, 24 insertions, 12 deletions
diff --git a/media-gfx/DFBPoint/ChangeLog b/media-gfx/DFBPoint/ChangeLog
index 29caef90f9d0..1ad83121e5b9 100644
--- a/media-gfx/DFBPoint/ChangeLog
+++ b/media-gfx/DFBPoint/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/DFBPoint
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/DFBPoint/ChangeLog,v 1.17 2012/05/05 07:00:26 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/DFBPoint/ChangeLog,v 1.18 2014/06/22 09:40:13 pacho Exp $
+
+ 22 Jun 2014; Pacho Ramos <pacho@gentoo.org> DFBPoint-0.7.2.ebuild:
+ Fix building due DEPRECATED warnings (#514050)
05 May 2012; Jeff Horelick <jdhore@gentoo.org> DFBPoint-0.7.2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/media-gfx/DFBPoint/DFBPoint-0.7.2.ebuild b/media-gfx/DFBPoint/DFBPoint-0.7.2.ebuild
index 0a491ca111f3..cfa52f2a9453 100644
--- a/media-gfx/DFBPoint/DFBPoint-0.7.2.ebuild
+++ b/media-gfx/DFBPoint/DFBPoint-0.7.2.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/DFBPoint/DFBPoint-0.7.2.ebuild,v 1.16 2012/05/05 07:00:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/DFBPoint/DFBPoint-0.7.2.ebuild,v 1.17 2014/06/22 09:40:13 pacho Exp $
+
+EAPI=5
+inherit gnome2-utils
DESCRIPTION="DFBPoint is presentation program based on DirectFB"
HOMEPAGE="http://www.directfb.org/index.php?path=Projects%2FDFBPoint"
@@ -11,23 +14,29 @@ SLOT="0"
KEYWORDS="~amd64 -sparc x86"
IUSE=""
-DEPEND="virtual/pkgconfig
+RDEPEND="
dev-libs/DirectFB
- >=dev-libs/glib-2"
-RDEPEND="dev-libs/DirectFB
- >=dev-libs/glib-2"
+ >=dev-libs/glib-2:2
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/glib-2
+"
+
+src_prepare() {
+ gnome2_disable_deprecation_warning
+}
src_install () {
- make DESTDIR="${D}" install || die "make install failed"
+ default
dodir /usr/share/DFBPoint/
- cp dfbpoint.dtd "${D}"/usr/share/DFBPoint/ || die "cp failed"
+ cp dfbpoint.dtd "${D}"/usr/share/DFBPoint/
dodoc AUTHORS ChangeLog INSTALL README NEWS
dodir /usr/share/DFBPoint/examples/
cd examples
cp bg.png bullet.png decker.ttf test.xml wilber_stoned.png \
- "${D}"/usr/share/DFBPoint/examples/ || die "cp failed"
- cp -R guadec/ "${D}"/usr/share/DFBPoint/examples/ || die "cp failed"
+ "${D}"/usr/share/DFBPoint/examples/
+ cp -R guadec/ "${D}"/usr/share/DFBPoint/examples/
}