summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-07 02:40:22 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-07 02:40:22 +0000
commit0285b5926f7d774b0573f3986f9c13fb7fb21821 (patch)
treedcc458a51796017ad3515ee254998f85f8825728 /media-libs/alsa-lib
parentget_libdir fixes. (Manifest recommit) (diff)
downloadgentoo-2-0285b5926f7d774b0573f3986f9c13fb7fb21821.tar.gz
gentoo-2-0285b5926f7d774b0573f3986f9c13fb7fb21821.tar.bz2
gentoo-2-0285b5926f7d774b0573f3986f9c13fb7fb21821.zip
get_libdir fixes, and no longer symlinking to old libasound lib.
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog6
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.6.ebuild19
2 files changed, 14 insertions, 11 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 2e0af04f24db..3593aa2f40ba 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.87 2004/10/03 00:19:01 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.88 2004/10/07 02:40:22 eradicator Exp $
+
+ 06 Oct 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ alsa-lib-1.0.6.ebuild:
+ get_libdir fixes, and no longer symlinking to old libasound lib.
02 Oct 2004; Jeremy Huddleston <eradicator@gentoo.org>
-alsa-lib-0.5.10b.ebuild, -alsa-lib-0.9.0_rc2.ebuild,
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.6.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.6.ebuild
index b7152c6d2e70..f581ee756267 100644
--- a/media-libs/alsa-lib/alsa-lib-1.0.6.ebuild
+++ b/media-libs/alsa-lib/alsa-lib-1.0.6.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.6.ebuild,v 1.3 2004/09/28 04:25:50 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.6.ebuild,v 1.4 2004/10/07 02:40:22 eradicator Exp $
IUSE="static jack"
-inherit libtool
+inherit libtool eutils
DESCRIPTION="Advanced Linux Sound Architecture Library"
HOMEPAGE="http://www.alsa-project.org/"
SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~alpha ~amd64 -sparc ~ia64 ~ppc64 ~hppa"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 -sparc ~ia64 ~ppc64 ~hppa ~mips"
LICENSE="GPL-2 LGPL-2.1"
RDEPEND="virtual/alsa
@@ -57,13 +57,8 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
- #This alsa version does not provide libasound.so.1
- #Without this library just about everything even remotely
- #linked to previous versions of alsa-lib will break.
- #Fortunately, libasound.so.2 seems to be backwards
- #compatible with libasound.so.1 and a simple link
- #fixes the problem (fingers crossed)
- dosym /usr/lib/libasound.so.2 /usr/lib/libasound.so.1
+ preserve_old_lib /usr/$(get_libdir)/libasound.so.1
+
dodoc ChangeLog COPYING TODO
if use static; then
@@ -71,3 +66,7 @@ src_install() {
make DESTDIR="${D}" install || die "make install failed"
fi
}
+
+src_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libasound.so.1
+}