summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-09-28 06:45:47 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-09-28 06:45:47 +0000
commit4d120792edae379fb2b625bf290c9e19fca973fd (patch)
tree557dc88686339c8a36d0baf530ce5798e4739bcc /media-libs/bio2jack/bio2jack-0.3-r1.ebuild
parentVersion bumpin' (Manifest recommit) (diff)
downloadgentoo-2-4d120792edae379fb2b625bf290c9e19fca973fd.tar.gz
gentoo-2-4d120792edae379fb2b625bf290c9e19fca973fd.tar.bz2
gentoo-2-4d120792edae379fb2b625bf290c9e19fca973fd.zip
Removing old versions. Revision bump to fix build tools to make the correct lib filename.
Diffstat (limited to 'media-libs/bio2jack/bio2jack-0.3-r1.ebuild')
-rw-r--r--media-libs/bio2jack/bio2jack-0.3-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/bio2jack/bio2jack-0.3-r1.ebuild b/media-libs/bio2jack/bio2jack-0.3-r1.ebuild
new file mode 100644
index 000000000000..6cfb8967dcba
--- /dev/null
+++ b/media-libs/bio2jack/bio2jack-0.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/bio2jack/bio2jack-0.3-r1.ebuild,v 1.1 2004/09/28 06:45:47 eradicator Exp $
+
+inherit libtool
+
+DESCRIPTION="A library for porting blocked I/O OSS/ALSA audio applications to JACK."
+HOMEPAGE="http://bio2jack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bio2jack/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+RDEPEND=">=media-sound/jack-audio-connection-kit-0.80"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.50"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ export WANT_AUTOMAKE=1.8
+ export WANT_AUTOCONF=2.5
+ aclocal || die
+ automake || die
+ autoconf || die
+ elibtoolize || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dobin bio2jack-config
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}