summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-02-19 23:08:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-02-19 23:08:41 +0000
commitd12cde7a439ce91a868601241ed961b8c4a8165d (patch)
tree53bf74e8eef0956f9b282c55f2c272bfa632858e /media-libs/faad2/faad2-2.7.ebuild
parentDrop stale kde 4.1.4 ebuilds (diff)
downloadgentoo-2-d12cde7a439ce91a868601241ed961b8c4a8165d.tar.gz
gentoo-2-d12cde7a439ce91a868601241ed961b8c4a8165d.tar.bz2
gentoo-2-d12cde7a439ce91a868601241ed961b8c4a8165d.zip
version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/faad2/faad2-2.7.ebuild')
-rw-r--r--media-libs/faad2/faad2-2.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/faad2/faad2-2.7.ebuild b/media-libs/faad2/faad2-2.7.ebuild
new file mode 100644
index 000000000000..4a080937ec00
--- /dev/null
+++ b/media-libs/faad2/faad2-2.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/faad2/faad2-2.7.ebuild,v 1.1 2009/02/19 23:08:41 aballier Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="AAC audio decoding library"
+HOMEPAGE="http://www.audiocoding.com/"
+SRC_URI="mirror://sourceforge/faac/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="digitalradio"
+
+RDEPEND=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_with digitalradio drm)\
+ --without-xmms
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README README.linux TODO
+}