summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-07-08 22:58:10 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-07-08 22:58:10 +0000
commitec0e158d54a947774c3fbfd503f7d21d4be2ac63 (patch)
tree6d1ae58c6842e9c07145228b6329cac9d696ed96 /media-libs/flac/flac-1.0.3.ebuild
parentLicense adds (diff)
downloadgentoo-2-ec0e158d54a947774c3fbfd503f7d21d4be2ac63.tar.gz
gentoo-2-ec0e158d54a947774c3fbfd503f7d21d4be2ac63.tar.bz2
gentoo-2-ec0e158d54a947774c3fbfd503f7d21d4be2ac63.zip
flac update (1.0.3) and repoman fixes too
Diffstat (limited to 'media-libs/flac/flac-1.0.3.ebuild')
-rw-r--r--media-libs/flac/flac-1.0.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/flac/flac-1.0.3.ebuild b/media-libs/flac/flac-1.0.3.ebuild
new file mode 100644
index 000000000000..023da8a5527c
--- /dev/null
+++ b/media-libs/flac/flac-1.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.0.3.ebuild,v 1.1 2002/07/08 22:58:10 drobbins Exp $
+
+DESCRIPTION="A free lossless audio encoder"
+SRC_URI="mirror://sourceforge/flac/${P}.tar.gz"
+HOMEPAGE="http://flac.sourceforge.net/"
+#flac has an optional xmms plugin. For now, we just depend on xmms. We can optimize this later.
+RDEPEND="virtual/glibc X? ( >=media-sound/xmms-1.2.5-r2 ) >=media-libs/libogg-1.0_rc2"
+DEPEND="virtual/glibc dev-lang/nasm sys-apps/gawk $RDEPEND"
+KEYWORDS="*"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+
+src_compile() {
+ cd ${S}
+ local myflags
+ [ `use sse` ] && myflags="--enable-sse"
+ #--use-3dnow is documented but apparently not yet enabled.
+ #[ `use 3dnow` ] && myflags="$myflags --use-3dnow"
+ ./configure --prefix=/usr $myflags --host=$CHOST || die
+ cp Makefile Makefile.orig
+ #the man page ebuild requires docbook2man... yick!
+ sed -e 's:include man:include:g' Makefile.orig > Makefile
+ #emake seems to mess up the building of the xmms input plugin
+ make || die
+}
+src_install() {
+ #it looks like we need to run the xmms install first
+ ( cd src/plugin_xmms; make DESTDIR=${D} install )
+ make DESTDIR=${D} install
+}
+
+