summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-13 21:45:03 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-13 21:45:03 +0000
commit6c3a9f2d626a8a5890c659e938bd2ff3182fa084 (patch)
treed49699ad964bd2de4cd8fa1fc0ef8bdf242e1c3e /media-libs/flac/flac-1.2.1-r3.ebuild
parentVersion bump, also fixes bug 218101. (diff)
downloadgentoo-2-6c3a9f2d626a8a5890c659e938bd2ff3182fa084.tar.gz
gentoo-2-6c3a9f2d626a8a5890c659e938bd2ff3182fa084.tar.bz2
gentoo-2-6c3a9f2d626a8a5890c659e938bd2ff3182fa084.zip
Don't build tests and examples which aren't installed anyway wrt bug 226301.
(Portage version: 2.1.5.5)
Diffstat (limited to 'media-libs/flac/flac-1.2.1-r3.ebuild')
-rw-r--r--media-libs/flac/flac-1.2.1-r3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/flac/flac-1.2.1-r3.ebuild b/media-libs/flac/flac-1.2.1-r3.ebuild
new file mode 100644
index 000000000000..47f3cf82a52e
--- /dev/null
+++ b/media-libs/flac/flac-1.2.1-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.2.1-r3.ebuild,v 1.1 2008/06/13 21:45:02 loki_val Exp $
+
+EAPI=1
+
+inherit autotools eutils base
+
+DESCRIPTION="free lossless audio encoder and decoder"
+HOMEPAGE="http://flac.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="3dnow altivec +cxx debug doc ogg sse test"
+
+RDEPEND="ogg? ( >=media-libs/libogg-1.1.3 )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ !elibc_uclibc? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-asneeded.patch"
+ "${FILESDIR}/${P}-cflags.patch"
+ "${FILESDIR}/${P}-asm.patch"
+ "${FILESDIR}/${P}-tests-optional.patch"
+ "${FILESDIR}/${P}-gcc-4.3-includes.patch" )
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable ogg) \
+ $(use_enable sse) \
+ $(use_enable 3dnow) \
+ $(use_enable altivec) \
+ $(use_enable debug) \
+ $(use_enable cxx cpplibs) \
+ --disable-examples \
+ --disable-tests \
+ --disable-doxygen-docs \
+ --disable-dependency-tracking \
+ --disable-xmms-plugin
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ rm -rf "${D}"/usr/share/doc/${P}
+ dodoc AUTHORS README
+ use doc && dohtml -r doc/html/*
+}