summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-07-12 04:13:13 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-07-12 04:13:13 +0000
commit3063543d941493cfc49bfc0c3dcddca20a2018cf (patch)
tree3f44a2878a6184677982977e562f5a3028827668 /media-libs/fontconfig
parentversion bump (diff)
downloadgentoo-2-3063543d941493cfc49bfc0c3dcddca20a2018cf.tar.gz
gentoo-2-3063543d941493cfc49bfc0c3dcddca20a2018cf.tar.bz2
gentoo-2-3063543d941493cfc49bfc0c3dcddca20a2018cf.zip
Version bump.
- Tweak order of preference for latin fonts (bug 130466) - Don't overwrite user settings on every reinstall (bug 193476) (Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/fontconfig')
-rw-r--r--media-libs/fontconfig/ChangeLog14
-rw-r--r--media-libs/fontconfig/files/fontconfig-2.7.0-latin-reorder.patch48
-rw-r--r--media-libs/fontconfig/fontconfig-2.7.0.ebuild128
3 files changed, 188 insertions, 2 deletions
diff --git a/media-libs/fontconfig/ChangeLog b/media-libs/fontconfig/ChangeLog
index 3738b2757046..466bb596ed6a 100644
--- a/media-libs/fontconfig/ChangeLog
+++ b/media-libs/fontconfig/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-libs/fontconfig
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.132 2009/03/07 19:10:43 betelgeuse Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.133 2009/07/12 04:13:12 dirtyepic Exp $
+
+*fontconfig-2.7.0 (12 Jul 2009)
+
+ 12 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> +fontconfig-2.7.0.ebuild,
+ +files/fontconfig-2.7.0-latin-reorder.patch:
+ Version bump.
+
+ - Tweak order of preference for latin fonts (bug 130466)
+
+ - Don't overwrite user settings on every reinstall (bug 193476)
07 Mar 2009; Petteri Räty <betelgeuse@gentoo.org>
fontconfig-2.6.0-r2.ebuild:
diff --git a/media-libs/fontconfig/files/fontconfig-2.7.0-latin-reorder.patch b/media-libs/fontconfig/files/fontconfig-2.7.0-latin-reorder.patch
new file mode 100644
index 000000000000..0a7221cd2a4a
--- /dev/null
+++ b/media-libs/fontconfig/files/fontconfig-2.7.0-latin-reorder.patch
@@ -0,0 +1,48 @@
+--- fontconfig-2.5.93/conf.d/60-latin.conf.mdvconfig
++++ fontconfig-2.5.93/conf.d/60-latin.conf
+@@ -4,8 +4,8 @@
+ <alias>
+ <family>serif</family>
+ <prefer>
+- <family>Bitstream Vera Serif</family>
+ <family>DejaVu Serif</family>
++ <family>Bitstream Vera Serif</family>
+ <family>Times New Roman</family>
+ <family>Thorndale AMT</family>
+ <family>Luxi Serif</family>
+@@ -16,14 +16,14 @@
+ <alias>
+ <family>sans-serif</family>
+ <prefer>
+- <family>Bitstream Vera Sans</family>
+ <family>DejaVu Sans</family>
+- <family>Verdana</family>
+- <family>Arial</family>
+- <family>Albany AMT</family>
++ <family>Bitstream Vera Sans</family>
+ <family>Luxi Sans</family>
+ <family>Nimbus Sans L</family>
++ <family>Arial</family>
++ <family>Albany AMT</family>
+ <family>Helvetica</family>
++ <family>Verdana</family>
+ <family>Lucida Sans Unicode</family>
+ <family>BPG Glaho International</family> <!-- lat,cyr,arab,geor -->
+ <family>Tahoma</family> <!-- lat,cyr,greek,heb,arab,thai -->
+@@ -32,13 +32,13 @@
+ <alias>
+ <family>monospace</family>
+ <prefer>
+- <family>Bitstream Vera Sans Mono</family>
+ <family>DejaVu Sans Mono</family>
++ <family>Bitstream Vera Sans Mono</family>
++ <family>Luxi Mono</family>
++ <family>Nimbus Mono L</family>
+ <family>Andale Mono</family>
+ <family>Courier New</family>
+ <family>Cumberland AMT</family>
+- <family>Luxi Mono</family>
+- <family>Nimbus Mono L</family>
+ <family>Courier</family>
+ </prefer>
+ </alias>
diff --git a/media-libs/fontconfig/fontconfig-2.7.0.ebuild b/media-libs/fontconfig/fontconfig-2.7.0.ebuild
new file mode 100644
index 000000000000..99a945ecb639
--- /dev/null
+++ b/media-libs/fontconfig/fontconfig-2.7.0.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.7.0.ebuild,v 1.1 2009/07/12 04:13:12 dirtyepic Exp $
+
+EAPI="2"
+
+inherit eutils libtool toolchain-funcs flag-o-matic
+
+DESCRIPTION="A library for configuring and customizing font access"
+HOMEPAGE="http://fontconfig.org/"
+SRC_URI="http://fontconfig.org/release/${P}.tar.gz"
+
+LICENSE="fontconfig"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="doc"
+
+# Purposefully dropped the xml USE flag and libxml2 support. Having this is
+# silly since expat is the preferred way to go per upstream and libxml2 support
+# simply exists as a fallback when expat isn't around. expat support is the main
+# way to go and every other distro uses it. By using the xml USE flag to enable
+# libxml2 support, this confuses users and results in most people getting the
+# non-standard behavior of libxml2 usage since most profiles have USE=xml
+
+RDEPEND=">=media-libs/freetype-2.2.1
+ >=dev-libs/expat-1.95.3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? (
+ app-text/docbook-sgml-utils[jadetex]
+ =app-text/docbook-sgml-dtd-3.1*
+ )"
+PDEPEND="app-admin/eselect-fontconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-latin-reorder.patch #130466
+ epunt_cxx #74077
+
+ # Needed to get a sane .so versioning on fbsd, please dont drop
+ # If you have to run eautoreconf, you can also leave the elibtoolize call as
+ # it will be a no-op.
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+ if tc-is-cross-compiler; then
+ myconf="--with-arch=${ARCH}"
+ replace-flags -mtune=* -DMTUNE_CENSORED
+ replace-flags -march=* -DMARCH_CENSORED
+ fi
+ econf $(use_enable doc docs) \
+ --localstatedir=/var \
+ --with-docdir=/usr/share/doc/${PF} \
+ --with-default-fonts=/usr/share/fonts \
+ --with-add-fonts=/usr/local/share/fonts \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ #fc-lang directory contains language coverage datafiles
+ #which are needed to test the coverage of fonts.
+ insinto /usr/share/fc-lang
+ doins fc-lang/*.orth
+
+ insinto /etc/fonts
+ doins "${S}"/fonts.conf
+
+ doman $(find "${S}" -type f -name *.1 -print)
+ newman doc/fonts-conf.5 fonts.conf.5
+ dodoc doc/fontconfig-user.{txt,pdf}
+
+ if use doc; then
+ doman doc/Fc*.3
+ dohtml doc/fontconfig-devel.html
+ dodoc doc/fontconfig-devel.{txt,pdf}
+ fi
+
+ dodoc AUTHORS ChangeLog README || die
+
+ # Changes should be made to /etc/fonts/local.conf, and as we had
+ # too much problems with broken fonts.conf, we force update it ...
+ # <azarah@gentoo.org> (11 Dec 2002)
+ echo 'CONFIG_PROTECT_MASK="/etc/fonts/fonts.conf"' > "${T}"/37fontconfig
+ doenvd "${T}"/37fontconfig
+}
+
+pkg_preinst() {
+ # Bug #193476
+ # /etc/fonts/conf.d/ contains symlinks to ../conf.avail/ to include various
+ # config files. If we install as-is, we'll blow away user settings.
+
+ ebegin "Syncing fontconfig configuration to system"
+ if [[ -e ${ROOT}/etc/fonts/conf.d ]]; then
+ for file in "${ROOT}"/etc/fonts/conf.avail/*; do
+ f=${file##*/}
+ if [[ -L ${ROOT}/etc/fonts/conf.d/${f} ]]; then
+ [[ -f ${D}etc/fonts/conf.avail/${f} ]] \
+ && ln -sf ../conf.avail/"${f}" "${D}"etc/fonts/conf.d/ &>/dev/null
+ else
+ [[ -f ${D}etc/fonts/conf.avail/${f} ]] \
+ && rm "${D}"etc/fonts/conf.d/"${f}" &>/dev/null
+ fi
+ done
+ fi
+ eend $?
+}
+
+pkg_postinst() {
+ einfo "Cleaning broken symlinks in "${ROOT}"etc/fonts/conf.d/"
+ find -L "${ROOT}"etc/fonts/conf.d/ -type l -delete
+
+ echo
+ ewarn "Please make fontconfig configuration changes using \`eselect fontconfig\`"
+ ewarn "Any changes made to /etc/fonts/fonts.conf will be overwritten."
+ ewarn
+ ewarn "If you need to reset your configuration to upstream defaults, delete"
+ ewarn "the directory ${ROOT}etc/fonts/conf.d/ and re-emerge fontconfig."
+ echo
+
+ if [[ ${ROOT} = / ]]; then
+ ebegin "Creating global font cache"
+ /usr/bin/fc-cache -sr
+ eend $?
+ fi
+}