summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-02-02 02:31:03 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-02-02 02:31:03 +0000
commit72b8fc9c0413b91843e824305c4e2f710268e16f (patch)
treebcbddd5d188c176263ed3fef4a6e3f3efcbae40a /media-libs/ftgl
parentMark 0.5.5.1-r3 stable on ia64 (diff)
downloadgentoo-2-72b8fc9c0413b91843e824305c4e2f710268e16f.tar.gz
gentoo-2-72b8fc9c0413b91843e824305c4e2f710268e16f.tar.bz2
gentoo-2-72b8fc9c0413b91843e824305c4e2f710268e16f.zip
Add a GCC 4.1 compile fix per #120835.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'media-libs/ftgl')
-rw-r--r--media-libs/ftgl/ChangeLog8
-rw-r--r--media-libs/ftgl/files/ftgl-2.1.2-gcc41.patch11
-rw-r--r--media-libs/ftgl/ftgl-2.1.2-r1.ebuild5
3 files changed, 20 insertions, 4 deletions
diff --git a/media-libs/ftgl/ChangeLog b/media-libs/ftgl/ChangeLog
index 99c7a7035c63..5adae4f53fe4 100644
--- a/media-libs/ftgl/ChangeLog
+++ b/media-libs/ftgl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/ftgl
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ftgl/ChangeLog,v 1.5 2005/12/10 21:13:49 tgall Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ftgl/ChangeLog,v 1.6 2006/02/02 02:31:03 joshuabaergen Exp $
+
+ 02 Feb 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +files/ftgl-2.1.2-gcc41.patch, ftgl-2.1.2-r1.ebuild:
+ Add a GCC 4.1 compile fix per #120835.
10 Dec 2005; Tom Gall <tgall@gentoo.org> ftgl-2.1.2-r1.ebuild:
added ~ppc64
diff --git a/media-libs/ftgl/files/ftgl-2.1.2-gcc41.patch b/media-libs/ftgl/files/ftgl-2.1.2-gcc41.patch
new file mode 100644
index 000000000000..c23aaacaf0a4
--- /dev/null
+++ b/media-libs/ftgl/files/ftgl-2.1.2-gcc41.patch
@@ -0,0 +1,11 @@
+--- FTGL/include/FTTextureGlyph.h.old 2006-01-29 11:08:54.000000000 -0700
++++ FTGL/include/FTTextureGlyph.h 2006-01-29 11:09:06.000000000 -0700
+@@ -52,7 +52,7 @@
+ * Reset the currently active texture to zero to get into a known state before
+ * drawing a string. This is to get round possible threading issues.
+ */
+- static void FTTextureGlyph::ResetActiveTexture(){ activeTextureID = 0;}
++ static void ResetActiveTexture(){ activeTextureID = 0;}
+
+ private:
+ /**
diff --git a/media-libs/ftgl/ftgl-2.1.2-r1.ebuild b/media-libs/ftgl/ftgl-2.1.2-r1.ebuild
index 267a58f0e54d..64086871befc 100644
--- a/media-libs/ftgl/ftgl-2.1.2-r1.ebuild
+++ b/media-libs/ftgl/ftgl-2.1.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ftgl/ftgl-2.1.2-r1.ebuild,v 1.2 2005/12/10 21:13:49 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ftgl/ftgl-2.1.2-r1.ebuild,v 1.3 2006/02/02 02:31:03 joshuabaergen Exp $
inherit eutils libtool
@@ -25,6 +25,7 @@ src_unpack() {
# Use the correct includedir for pkg-config
epatch "${FILESDIR}/${PV}-ftgl.pc.in.patch"
+ epatch "${FILESDIR}/${P}-gcc41.patch"
if ! has_version app-doc/doxygen; then
cd FTGL/docs
tar xzf html.tar.gz || die "unpack html.tar.gz"