summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-05-04 07:46:24 +0000
committerTim Harder <radhermit@gentoo.org>2011-05-04 07:46:24 +0000
commit1d30f8e9e71d9a3d820991e498f3e85bdec6bbfb (patch)
treeb46fe61d8f4153c0e2e1f73e6b686ede8e0fd685 /media-libs/glew/glew-1.6.0.ebuild
parentversion bump (diff)
downloadgentoo-2-1d30f8e9e71d9a3d820991e498f3e85bdec6bbfb.tar.gz
gentoo-2-1d30f8e9e71d9a3d820991e498f3e85bdec6bbfb.tar.bz2
gentoo-2-1d30f8e9e71d9a3d820991e498f3e85bdec6bbfb.zip
Version bump.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/glew/glew-1.6.0.ebuild')
-rw-r--r--media-libs/glew/glew-1.6.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/glew/glew-1.6.0.ebuild b/media-libs/glew/glew-1.6.0.ebuild
new file mode 100644
index 000000000000..c2e3af4d330d
--- /dev/null
+++ b/media-libs/glew/glew-1.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glew/glew-1.6.0.ebuild,v 1.1 2011/05/04 07:46:24 radhermit Exp $
+
+EAPI=4
+inherit multilib toolchain-funcs
+
+DESCRIPTION="The OpenGL Extension Wrangler Library"
+HOMEPAGE="http://glew.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libXmu
+ x11-libs/libXi
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ myglewopts=(
+ AR="$(tc-getAR)"
+ STRIP=true
+ CC="$(tc-getCC)"
+ LD="$(tc-getCC) ${LDFLAGS}"
+ M_ARCH=""
+ LDFLAGS.EXTRA=""
+ POPT="${CFLAGS}"
+ )
+}
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s:-s::' \
+ -e '/$(CC) $(CFLAGS) -o/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
+ Makefile || die
+
+ # don't do stupid Solaris specific stuff that won't work in Prefix
+ cp config/Makefile.linux config/Makefile.solaris || die
+}
+
+src_compile(){
+ emake "${myglewopts[@]}"
+}
+
+src_install() {
+ emake \
+ GLEW_DEST="${ED}/usr" \
+ LIBDIR="${ED}/usr/$(get_libdir)" \
+ "${myglewopts[@]}" install
+
+ dodoc doc/*.txt README.txt TODO.txt
+ dohtml doc/*.{css,html,jpg,png}
+}