summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-21 06:07:48 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-21 06:07:48 +0000
commit1f0c0fc7dc18f5016e67bcd904a3b7491bc6c77b (patch)
tree30628f5c57252411e1dfd8aed2c0864a99e50a83 /media-libs/glide-v3
parentVersion bump. Some minor upstream fixes and tweaks. See bug #38880. (Manife... (diff)
downloadgentoo-2-1f0c0fc7dc18f5016e67bcd904a3b7491bc6c77b.tar.gz
gentoo-2-1f0c0fc7dc18f5016e67bcd904a3b7491bc6c77b.tar.bz2
gentoo-2-1f0c0fc7dc18f5016e67bcd904a3b7491bc6c77b.zip
add IUSE #38873
Diffstat (limited to 'media-libs/glide-v3')
-rw-r--r--media-libs/glide-v3/glide-v3-3.10-r3.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/media-libs/glide-v3/glide-v3-3.10-r3.ebuild b/media-libs/glide-v3/glide-v3-3.10-r3.ebuild
index 32bf64e1f94f..17e07a33933f 100644
--- a/media-libs/glide-v3/glide-v3-3.10-r3.ebuild
+++ b/media-libs/glide-v3/glide-v3-3.10-r3.ebuild
@@ -1,34 +1,30 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/glide-v3/glide-v3-3.10-r3.ebuild,v 1.11 2003/10/03 14:15:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glide-v3/glide-v3-3.10-r3.ebuild,v 1.12 2004/01/21 06:07:48 vapier Exp $
# NOTE: Do NOT build this with optimizations, as it will make this package
# unstable!!!!
S=${WORKDIR}/${PN/-v3/3x}
DESCRIPTION="Hardware support for the voodoo3, voodoo4 and voodoo5"
+HOMEPAGE="http://glide.sourceforge.net/"
SRC_URI="http://www.ibiblio.org/gentoo/distfiles/glide3x-${PV}.tar.gz
http://www.ibiblio.org/gentoo/distfiles/swlibs-${PV}.tar.gz"
# check for future updates here
# http://telia.dl.sourceforge.net/mirrors/slackware/slackware-8.0/contrib/contrib-sources/3dfx/voodoo4_voodoo5/
-HOMEPAGE="http://glide.sourceforge.net/"
-SLOT="0"
LICENSE="3DFX"
+SLOT="0"
KEYWORDS="x86 sparc alpha"
+IUSE="voodoo3"
DEPEND=">=sys-devel/automake-1.4
>=sys-devel/autoconf-2.13
>=sys-devel/libtool-1.3.3
>=sys-devel/m4-1.4
>=dev-lang/perl-5.005"
-
PROVIDE="virtual/glide"
-use voodoo3 \
- && compilefor="h3" \
- || compilefor="h5"
-
src_unpack() {
unpack ${A}
@@ -44,11 +40,17 @@ src_unpack() {
}
src_compile() {
+ local compilefor=
+ use voodoo3 \
+ && compilefor="h3" \
+ || compilefor="h5"
mkdir build
cd build
- ../configure --prefix=/usr \
+ ../configure \
+ --prefix=/usr \
--enable-fx-glide-hw=${compilefor} \
- --enable-fx-dri-build || die
+ --enable-fx-dri-build \
+ || die
# On alpha at least, glide incorrectly guesses 486 processor.
# Fixup the makefiles.