summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-05-11 03:15:30 +0000
committerOlivier Crête <tester@gentoo.org>2009-05-11 03:15:30 +0000
commiteff78fcb00857ef4cede1936704fdb220739c5c2 (patch)
tree3aee2b063eef7075de7d7b2c6710a67a8b8044ec /media-libs/gst-plugins-base/gst-plugins-base-0.10.23.ebuild
parentVersion bump (diff)
downloadgentoo-2-eff78fcb00857ef4cede1936704fdb220739c5c2.tar.gz
gentoo-2-eff78fcb00857ef4cede1936704fdb220739c5c2.tar.bz2
gentoo-2-eff78fcb00857ef4cede1936704fdb220739c5c2.zip
Version bump
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gst-plugins-base/gst-plugins-base-0.10.23.ebuild')
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.23.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.23.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.23.ebuild
new file mode 100644
index 000000000000..40943b3e6ded
--- /dev/null
+++ b/media-libs/gst-plugins-base/gst-plugins-base-0.10.23.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.23.ebuild,v 1.1 2009/05/11 03:15:30 tester Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-base gst-plugins10 gnome2 flag-o-matic eutils
+# libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=media-libs/gstreamer-0.10.23
+ >=dev-libs/liboil-0.3.14o
+ !<media-libs/gst-plugins-bad-0.10.10"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.11.5 )
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS README RELEASE"
+
+src_compile() {
+ # gst doesnt handle opts well, last tested with 0.10.15
+ strip-flags
+ replace-flags "-O3" "-O2"
+
+ gst-plugins-base_src_configure \
+ $(use_enable nls)
+ emake || die "emake failed."
+}
+
+src_install() {
+ gnome2_src_install
+}