summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-02 17:23:40 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-02 17:23:40 +0000
commita8977396680207293b2d25526fc2c103d7f529ee (patch)
tree1e0cc8b095e162a83f882b4be97e4f39e27737e0 /media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild
parentImport cleaned up ebuild from gnome overlay. (diff)
downloadgentoo-2-a8977396680207293b2d25526fc2c103d7f529ee.tar.gz
gentoo-2-a8977396680207293b2d25526fc2c103d7f529ee.tar.bz2
gentoo-2-a8977396680207293b2d25526fc2c103d7f529ee.zip
Clean up old revisions. Update ebuild to use new eclasses.
(Portage version: 2.2.0_alpha143/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild')
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild51
1 files changed, 27 insertions, 24 deletions
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild
index fdf730638036..a5fe38e15b07 100644
--- a/media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild
+++ b/media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild
@@ -1,48 +1,49 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild,v 1.3 2012/11/07 21:20:49 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild,v 1.4 2012/12/02 17:23:40 eva Exp $
-EAPI="4"
-GCONF_DEBUG="no"
+EAPI="5"
-# order is important, gnome2 after gst-plugins
-inherit gst-plugins-base gst-plugins10 gnome2 eutils multilib
-# libtool
+inherit gst-plugins-base gst-plugins10
DESCRIPTION="Basepack of plugins for gstreamer"
HOMEPAGE="http://gstreamer.freedesktop.org/"
-SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
LICENSE="GPL-2+ LGPL-2+"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="+introspection nls +orc"
-RDEPEND=">=dev-libs/glib-2.22:2
+RDEPEND=">=dev-libs/glib-2.24:2
>=media-libs/gstreamer-${PV}:0.10[introspection?]
dev-libs/libxml2:2
sys-libs/zlib
app-text/iso-codes
introspection? ( >=dev-libs/gobject-introspection-0.9.12 )
orc? ( >=dev-lang/orc-0.4.11 )
- !<media-libs/gst-plugins-bad-0.10.10:0.10"
+"
DEPEND="${RDEPEND}
- app-arch/xz-utils
- dev-util/gtk-doc-am
- virtual/pkgconfig
- nls? ( >=sys-devel/gettext-0.11.5 )"
+ >=dev-util/gtk-doc-am-1.3
+ nls? ( >=sys-devel/gettext-0.11.5 )
+"
+RDEPEND="${RDEPEND}
+ !<media-libs/gst-plugins-bad-0.10.10:0.10
+"
-GST_PLUGINS_BUILD=""
-
-DOCS="AUTHORS NEWS README RELEASE"
+src_prepare() {
+ # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
+ # though they are not actually used. This needs to be fixed upstream by
+ # replacing AC_PATH_XTRA with PKG_CONFIG calls.
+ sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure || die
+}
src_configure() {
- gst-plugins-base_src_configure \
+ gst-plugins10_src_configure \
$(use_enable introspection) \
$(use_enable nls) \
$(use_enable orc) \
- --disable-static \
--disable-examples \
- --disable-debug
+ --disable-debug \
+ --disable-static
# bug #366931, flag-o-matic for the whole thing is overkill
if [[ ${CHOST} == *86-*-darwin* ]] ; then
@@ -53,10 +54,12 @@ src_configure() {
fi
}
+src_compile() {
+ default
+}
+
src_install() {
- gnome2_src_install
- # Only remove .la files belonging to plugins; .la files for libraries are
- # needed for building other plugins belonging to the gst-plugins-base
- # tarball from media-plugins/gst-plugins-* ebuilds.
- find "${ED}usr/$(get_libdir)/gstreamer-0.10/" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ DOCS="AUTHORS NEWS README RELEASE"
+ default
+ prune_libtool_files --modules
}