summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-03 23:37:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-03 23:37:50 +0000
commit1fa089e49f927f79e5bab516efca2f99032ef8ce (patch)
tree73b1ed623fe4b8290f53d815f1a302404820794e /media-libs/gst-plugins-ugly
parentVersion bump. (diff)
downloadgentoo-2-1fa089e49f927f79e5bab516efca2f99032ef8ce.tar.gz
gentoo-2-1fa089e49f927f79e5bab516efca2f99032ef8ce.tar.bz2
gentoo-2-1fa089e49f927f79e5bab516efca2f99032ef8ce.zip
Version bump.
(Portage version: 2.2.0_alpha143/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-libs/gst-plugins-ugly')
-rw-r--r--media-libs/gst-plugins-ugly/ChangeLog8
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.0.3.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-ugly/ChangeLog b/media-libs/gst-plugins-ugly/ChangeLog
index 9415c6e11f46..463534b67ffa 100644
--- a/media-libs/gst-plugins-ugly/ChangeLog
+++ b/media-libs/gst-plugins-ugly/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-ugly
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.99 2012/12/02 22:53:18 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.100 2012/12/03 23:37:50 eva Exp $
+
+*gst-plugins-ugly-1.0.3 (03 Dec 2012)
+
+ 03 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ +gst-plugins-ugly-1.0.3.ebuild:
+ Version bump.
02 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org>
gst-plugins-ugly-0.10.18.ebuild, gst-plugins-ugly-0.10.19.ebuild:
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.0.3.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.0.3.ebuild
new file mode 100644
index 000000000000..20dae6d4bbe8
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.0.3.ebuild,v 1.1 2012/12/03 23:37:50 eva Exp $
+
+EAPI="5"
+
+# order is important, gst-plugins10 after gst-plugins
+inherit eutils flag-o-matic gst-plugins-ugly gst-plugins10
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=media-libs/gstreamer-1:${SLOT}
+ >=media-libs/gst-plugins-base-1:${SLOT}
+ orc? ( >=dev-lang/orc-0.4.16 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_configure() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins10_src_configure
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ default
+ prune_libtool_files --modules
+}