summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-03-01 07:53:49 +0000
committerPacho Ramos <pacho@gentoo.org>2014-03-01 07:53:49 +0000
commitad40203d7d06c5d3c6612d3798d1d5f4ee782b47 (patch)
tree7878684f1d0e7408edf6abe22f184ee297636522 /media-libs/gst-plugins-ugly
parentAdd missing header (#502178 by David W Noon and approved by M Welinder), drop... (diff)
downloadgentoo-2-ad40203d7d06c5d3c6612d3798d1d5f4ee782b47.tar.gz
gentoo-2-ad40203d7d06c5d3c6612d3798d1d5f4ee782b47.tar.bz2
gentoo-2-ad40203d7d06c5d3c6612d3798d1d5f4ee782b47.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-libs/gst-plugins-ugly')
-rw-r--r--media-libs/gst-plugins-ugly/ChangeLog10
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.0.ebuild6
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.3.ebuild44
3 files changed, 55 insertions, 5 deletions
diff --git a/media-libs/gst-plugins-ugly/ChangeLog b/media-libs/gst-plugins-ugly/ChangeLog
index ed8414a66c95..5a1d2b3fb195 100644
--- a/media-libs/gst-plugins-ugly/ChangeLog
+++ b/media-libs/gst-plugins-ugly/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-ugly
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.139 2013/10/22 07:20:22 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.140 2014/03/01 07:53:49 pacho Exp $
+
+*gst-plugins-ugly-1.2.3 (01 Mar 2014)
+
+ 01 Mar 2014; Pacho Ramos <pacho@gentoo.org> +gst-plugins-ugly-1.2.3.ebuild,
+ gst-plugins-ugly-1.2.0.ebuild:
+ Version bump
22 Oct 2013; Agostino Sarubbo <ago@gentoo.org> gst-plugins-ugly-1.0.10.ebuild:
Stable for sparc, wrt bug #480908
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.0.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.0.ebuild
index bd2c44545180..44eff63c84c5 100644
--- a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.0.ebuild
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.0.ebuild,v 1.2 2013/10/02 15:03:49 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.0.ebuild,v 1.3 2014/03/01 07:53:49 pacho Exp $
EAPI="5"
@@ -11,7 +11,7 @@ DESCRIPTION="Basepack of plugins for gstreamer"
HOMEPAGE="http://gstreamer.sourceforge.net"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
IUSE="+orc"
RDEPEND="
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.3.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.3.ebuild
new file mode 100644
index 000000000000..699884b02e51
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.2.3.ebuild,v 1.1 2014/03/01 07:53:49 pacho Exp $
+
+EAPI="5"
+
+# order is important, gst-plugins10 after gst-plugins
+inherit eutils flag-o-matic gst-plugins-ugly gst-plugins10
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=media-libs/gstreamer-1.2:${SLOT}
+ >=media-libs/gst-plugins-base-1.2:${SLOT}
+ orc? ( >=dev-lang/orc-0.4.16 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_configure() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins10_src_configure
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ default
+ prune_libtool_files --modules
+}