summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2011-02-24 05:18:57 +0000
committerMart Raudsepp <leio@gentoo.org>2011-02-24 05:18:57 +0000
commit1c967b730d88cd38af75cf4137c57cc075d789cc (patch)
tree0c05557a54a273301a330db5898b5be6b99752e7 /media-libs/gstreamer
parentEAPI 3, fix dependencies, remove .la files. (diff)
downloadgentoo-2-1c967b730d88cd38af75cf4137c57cc075d789cc.tar.gz
gentoo-2-1c967b730d88cd38af75cf4137c57cc075d789cc.tar.bz2
gentoo-2-1c967b730d88cd38af75cf4137c57cc075d789cc.zip
Version bump. valve, input-selector and output-selector elements have matured and moved from gst-plugins-bad to here, while ignoring the old ones if -bad isn't upgraded yet. Lots of performance improvements in heavily-used code paths. Many other improvements and bug fixes.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gstreamer')
-rw-r--r--media-libs/gstreamer/ChangeLog10
-rw-r--r--media-libs/gstreamer/gstreamer-0.10.32.ebuild57
2 files changed, 66 insertions, 1 deletions
diff --git a/media-libs/gstreamer/ChangeLog b/media-libs/gstreamer/ChangeLog
index 5cd70e4b08fb..dc38d0fe9373 100644
--- a/media-libs/gstreamer/ChangeLog
+++ b/media-libs/gstreamer/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/gstreamer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/ChangeLog,v 1.280 2011/02/20 21:51:05 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/ChangeLog,v 1.281 2011/02/24 05:18:57 leio Exp $
+
+*gstreamer-0.10.32 (24 Feb 2011)
+
+ 24 Feb 2011; Mart Raudsepp <leio@gentoo.org> +gstreamer-0.10.32.ebuild:
+ Version bump. valve, input-selector and output-selector elements have
+ matured and moved from gst-plugins-bad to here, while ignoring the old
+ ones if -bad isn't upgraded yet. Lots of performance improvements in
+ heavily-used code paths. Many other improvements and bug fixes.
20 Feb 2011; Markus Meier <maekke@gentoo.org> gstreamer-0.10.31.ebuild:
arm stable, bug #353434
diff --git a/media-libs/gstreamer/gstreamer-0.10.32.ebuild b/media-libs/gstreamer/gstreamer-0.10.32.ebuild
new file mode 100644
index 000000000000..8026bbebe4ce
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-0.10.32.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/gstreamer-0.10.32.ebuild,v 1.1 2011/02/24 05:18:57 leio Exp $
+
+EAPI=2
+
+inherit eutils multilib versionator
+
+# Create a major/minor combo for our SLOT and executables suffix
+PV_MAJ_MIN=$(get_version_component_range '1-2')
+
+DESCRIPTION="Streaming media framework"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://${PN}.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT=${PV_MAJ_MIN}
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+introspection nls test"
+
+RDEPEND=">=dev-libs/glib-2.22:2
+ dev-libs/libxml2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
+ !<media-libs/gst-plugins-base-0.10.26"
+ # ^^ queue2 move, mustn't have both libgstcoreleements.so and libgstqueue2.so at runtime providing the element at once
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+ # dev-util/gtk-doc-am # Only if eautoreconf'ing
+
+src_configure() {
+ # Disable static archives, dependency tracking and examples
+ # to speed up build time
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ --disable-valgrind \
+ --disable-examples \
+ --enable-check \
+ $(use_enable introspection) \
+ $(use_enable test tests) \
+ --with-package-name="GStreamer ebuild for Gentoo" \
+ --with-package-origin="http://packages.gentoo.org/package/media-libs/gstreamer"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE
+
+ # Remove unversioned binaries to allow SLOT installations in future
+ cd "${D}"/usr/bin
+ local gst_bins
+ for gst_bins in $(ls *-${PV_MAJ_MIN}); do
+ rm -f ${gst_bins/-${PV_MAJ_MIN}/}
+ done
+}