summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-08-23 00:52:55 +0000
committerMike Frysinger <vapier@gentoo.org>2009-08-23 00:52:55 +0000
commit2ec43c5f33a1a3b39d8b6158c42848492b7836c5 (patch)
tree8b144e420d5feeff1461ba39d00366db03e9a11d /media-libs/jpeg
parentcleanup patch (diff)
downloadgentoo-2-2ec43c5f33a1a3b39d8b6158c42848492b7836c5.tar.gz
gentoo-2-2ec43c5f33a1a3b39d8b6158c42848492b7836c5.tar.bz2
gentoo-2-2ec43c5f33a1a3b39d8b6158c42848492b7836c5.zip
Hook the extra subdir into the normal jpeg dir so we can re-use the configure environment and thus simplify the rest of the ebuild. Drop external libtool dep since jpeg bundles its own sane version.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/jpeg')
-rw-r--r--media-libs/jpeg/ChangeLog7
-rw-r--r--media-libs/jpeg/jpeg-7.ebuild32
2 files changed, 20 insertions, 19 deletions
diff --git a/media-libs/jpeg/ChangeLog b/media-libs/jpeg/ChangeLog
index ef6d1d0d51b6..2b1c4a6679c0 100644
--- a/media-libs/jpeg/ChangeLog
+++ b/media-libs/jpeg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/jpeg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.72 2009/08/22 12:16:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.73 2009/08/23 00:52:55 vapier Exp $
+
+ 23 Aug 2009; Mike Frysinger <vapier@gentoo.org> jpeg-7.ebuild:
+ Hook the extra subdir into the normal jpeg dir so we can re-use the
+ configure environment and thus simplify the rest of the ebuild. Drop
+ external libtool dep since jpeg bundles its own sane version.
22 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> jpeg-7.ebuild,
+files/jpeg-7-maxmem_sysconf.patch:
diff --git a/media-libs/jpeg/jpeg-7.ebuild b/media-libs/jpeg/jpeg-7.ebuild
index f5f904c4078f..2fee8b58d636 100644
--- a/media-libs/jpeg/jpeg-7.ebuild
+++ b/media-libs/jpeg/jpeg-7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-7.ebuild,v 1.3 2009/08/22 12:16:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-7.ebuild,v 1.4 2009/08/23 00:52:55 vapier Exp $
-EAPI=2
-inherit eutils libtool toolchain-funcs
+EAPI="2"
+inherit eutils libtool
DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
HOMEPAGE="http://www.ijg.org/"
@@ -15,13 +15,18 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
src_prepare() {
epatch "${FILESDIR}"/${P}-maxmem_sysconf.patch
elibtoolize
+
+ # hook the extra dir into the normal jpeg build env
+ mv ../${P}-extra extra
+ sed -i '/all:/s:$:\n\t$(MAKE) -C extra $@:' Makefile.in
+ # newer extra tarball has this integrated
+ cd extra
+ sed -e 's:mandir:man1dir:' Makefile > Makefile.in
+ grep ' = @' ../Makefile.in >> Makefile.in
+ printf 'all %%:\n\t../config.status --file=Makefile:Makefile.in\n\t$(MAKE) $@' > Makefile
}
src_configure() {
@@ -32,16 +37,7 @@ src_configure() {
--enable-maxmem=64
}
-src_compile() {
- emake || die "emake failed"
- tc-export CC
- emake -C "${WORKDIR}"/${P}-extra || die "emake failed"
-}
-
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- emake -C "${WORKDIR}"/${P}-extra DESTDIR="${D}" \
- install || die "emake install failed"
-
- dodoc example.c README *.{log,txt} || die "dodoc failed"
+ emake DESTDIR="${D}" install || die
+ dodoc example.c README *.{log,txt}
}