summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-11 20:51:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-11 20:51:56 +0000
commit2b486e22cafe1aea4c8a0572e7c9f77f330a676b (patch)
tree0f26d22e5e7c1f8329a0760fec526453509ba80c /media-libs/libaacplus
parentfreebsd-lib provides its own libelf now, adjust the deps, bug #479494 by Yuta... (diff)
downloadgentoo-2-2b486e22cafe1aea4c8a0572e7c9f77f330a676b.tar.gz
gentoo-2-2b486e22cafe1aea4c8a0572e7c9f77f330a676b.tar.bz2
gentoo-2-2b486e22cafe1aea4c8a0572e7c9f77f330a676b.zip
convert to multilib, goodbye autotools-utils crap that is a pain to work with here
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libaacplus')
-rw-r--r--media-libs/libaacplus/ChangeLog9
-rw-r--r--media-libs/libaacplus/libaacplus-2.0.2-r2.ebuild62
2 files changed, 70 insertions, 1 deletions
diff --git a/media-libs/libaacplus/ChangeLog b/media-libs/libaacplus/ChangeLog
index 0db306c9ba7a..c7567c130804 100644
--- a/media-libs/libaacplus/ChangeLog
+++ b/media-libs/libaacplus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libaacplus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libaacplus/ChangeLog,v 1.13 2013/05/03 13:37:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libaacplus/ChangeLog,v 1.14 2013/08/11 20:51:56 aballier Exp $
+
+*libaacplus-2.0.2-r2 (11 Aug 2013)
+
+ 11 Aug 2013; Alexis Ballier <aballier@gentoo.org>
+ +libaacplus-2.0.2-r2.ebuild:
+ convert to multilib, goodbye autotools-utils crap that is a pain to work with
+ here
*libaacplus-2.0.2-r1 (03 May 2013)
diff --git a/media-libs/libaacplus/libaacplus-2.0.2-r2.ebuild b/media-libs/libaacplus/libaacplus-2.0.2-r2.ebuild
new file mode 100644
index 000000000000..db620f71ad62
--- /dev/null
+++ b/media-libs/libaacplus/libaacplus-2.0.2-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libaacplus/libaacplus-2.0.2-r2.ebuild,v 1.1 2013/08/11 20:51:56 aballier Exp $
+
+EAPI=5
+
+inherit autotools multilib-minimal
+
+# This file cannot be mirrored.
+# See the notes at http://tipok.org.ua/node/17
+# The .tar.gz, ie the wrapper library, is lgpl though.
+TGPPDIST=26410-800.zip
+
+DESCRIPTION="HE-AAC+ v2 library, based on the reference implementation"
+HOMEPAGE="http://tipok.org.ua/node/17"
+SRC_URI="
+ http://dev.gentoo.org/~aballier/${P}.tar.gz
+ http://tipok.ath.cx/downloads/media/aac+/libaacplus/${P}.tar.gz
+ http://217.20.164.161/~tipok/aacplus/${P}.tar.gz
+ http://www.3gpp.org/ftp/Specs/archive/26_series/26.410/${TGPPDIST}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="bindist fftw static-libs"
+
+RESTRICT="mirror"
+REQUIRED_USE="!bindist"
+
+RDEPEND="
+ !media-sound/aacplusenc
+ fftw? ( sci-libs/fftw:3.0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_prepare() {
+ sed \
+ -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' \
+ -i configure.ac || die
+ eautoreconf
+ cp "${DISTDIR}/${TGPPDIST}" src/ || die
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_with fftw fftw3) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ emake -j1
+}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -exec rm -f {} +
+}