summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2003-05-03 01:39:29 +0000
committerBart Lauwers <blauwers@gentoo.org>2003-05-03 01:39:29 +0000
commitc1620730439cde49d99e3bc06055e87cf942a9ed (patch)
treea200a64b18fe2ef49d1f1890ac37f97250bbd999 /media-libs/libcddb/libcddb-0.9.2.ebuild
parentmark x86 (diff)
downloadgentoo-2-c1620730439cde49d99e3bc06055e87cf942a9ed.tar.gz
gentoo-2-c1620730439cde49d99e3bc06055e87cf942a9ed.tar.bz2
gentoo-2-c1620730439cde49d99e3bc06055e87cf942a9ed.zip
Initial import per Bug#20033
Diffstat (limited to 'media-libs/libcddb/libcddb-0.9.2.ebuild')
-rw-r--r--media-libs/libcddb/libcddb-0.9.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libcddb/libcddb-0.9.2.ebuild b/media-libs/libcddb/libcddb-0.9.2.ebuild
new file mode 100644
index 000000000000..de8f0f9ede88
--- /dev/null
+++ b/media-libs/libcddb/libcddb-0.9.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcddb/libcddb-0.9.2.ebuild,v 1.1 2003/05/03 01:39:29 blauwers Exp $
+
+IUSE="doc"
+
+DESCRIPTION="A library for accessing a CDDB server"
+HOMEPAGE="http://libcddb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+
+src_compile() {
+ econf || die
+ emake || die
+
+ # Create API docs if needed and possible
+ if use doc && has_version 'app-doc/doxygen'; then
+ cd doc
+ doxygen doxygen.conf
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install
+
+ dodoc AUTHORS Changelog COPYING INSTALL NEWS README THANKS TODO
+ # Create API docs if needed and possible
+ if use doc && has_version 'app-doc/doxygen'; then
+ dohtml doc/html/*
+ fi
+}