summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2014-04-14 10:50:12 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2014-04-14 10:50:12 +0000
commit100f81b432d425334345659a65ee2d9a6e77a271 (patch)
treebbedf271164a7cfa966a1e744fbe728d42704060 /media-libs/libcdr/libcdr-0.0.16.ebuild
parentVersion bump. (diff)
downloadgentoo-2-100f81b432d425334345659a65ee2d9a6e77a271.tar.gz
gentoo-2-100f81b432d425334345659a65ee2d9a6e77a271.tar.bz2
gentoo-2-100f81b432d425334345659a65ee2d9a6e77a271.zip
Bump to hotfix release. Update license to match reality.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'media-libs/libcdr/libcdr-0.0.16.ebuild')
-rw-r--r--media-libs/libcdr/libcdr-0.0.16.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/libcdr/libcdr-0.0.16.ebuild b/media-libs/libcdr/libcdr-0.0.16.ebuild
new file mode 100644
index 000000000000..1b66d5245187
--- /dev/null
+++ b/media-libs/libcdr/libcdr-0.0.16.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcdr/libcdr-0.0.16.ebuild,v 1.1 2014/04/14 10:50:12 scarabeus Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-2
+
+DESCRIPTION="Library parsing the Corel cdr documents"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libcdr"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.9
+ app-text/libwpg:0.2
+ dev-libs/icu:=
+ media-libs/lcms:2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ base_src_prepare
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}