summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-04-19 20:46:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-04-19 20:46:24 +0000
commit86f70c70e8794cfd68aa32cccfad914d273c6a4d (patch)
tree7f412631daa452370496ffa754f7bcd00f1ff281 /media-libs/libclthreads/libclthreads-2.2.1.ebuild
parentnet-libs/libpcap: Add cross compile test for bug #172210 (diff)
downloadgentoo-2-86f70c70e8794cfd68aa32cccfad914d273c6a4d.tar.gz
gentoo-2-86f70c70e8794cfd68aa32cccfad914d273c6a4d.tar.bz2
gentoo-2-86f70c70e8794cfd68aa32cccfad914d273c6a4d.zip
Version bump, thanks to Mike Mattie and ron widler, bug #156914
(Portage version: 2.1.2.4)
Diffstat (limited to 'media-libs/libclthreads/libclthreads-2.2.1.ebuild')
-rw-r--r--media-libs/libclthreads/libclthreads-2.2.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/libclthreads/libclthreads-2.2.1.ebuild b/media-libs/libclthreads/libclthreads-2.2.1.ebuild
new file mode 100644
index 000000000000..4d44ee01c040
--- /dev/null
+++ b/media-libs/libclthreads/libclthreads-2.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libclthreads/libclthreads-2.2.1.ebuild,v 1.1 2007/04/19 20:46:24 aballier Exp $
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="${P/lib/}"
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="An audio library by Fons Adriaensen <fons.adriaensen@skynet.be>"
+HOMEPAGE="http://www.kokkinizita.net/linuxaudio/"
+SRC_URI="http://www.kokkinizita.net/linuxaudio/downloads/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ tc-export CC CXX
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake CLTHREADS_LIBDIR="/usr/$(get_libdir)" DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS
+}