summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-13 14:25:11 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-13 14:25:11 +0000
commit77a798ffe55c243fcb128ffffa5566cf778849b5 (patch)
treed0548ad4072848e86f7e3026dcdd004c505df221 /media-libs/libdsp
parentQA: Use full atoms for best_version, has_version and built_with_use queries. (diff)
downloadgentoo-2-77a798ffe55c243fcb128ffffa5566cf778849b5.tar.gz
gentoo-2-77a798ffe55c243fcb128ffffa5566cf778849b5.tar.bz2
gentoo-2-77a798ffe55c243fcb128ffffa5566cf778849b5.zip
QA: Fix has_version atoms.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-libs/libdsp')
-rw-r--r--media-libs/libdsp/libdsp-4.9.2-r1.ebuild12
-rw-r--r--media-libs/libdsp/libdsp-4.9.2.ebuild12
2 files changed, 6 insertions, 18 deletions
diff --git a/media-libs/libdsp/libdsp-4.9.2-r1.ebuild b/media-libs/libdsp/libdsp-4.9.2-r1.ebuild
index 010d35736c7d..51d8d7a2cb77 100644
--- a/media-libs/libdsp/libdsp-4.9.2-r1.ebuild
+++ b/media-libs/libdsp/libdsp-4.9.2-r1.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdsp/libdsp-4.9.2-r1.ebuild,v 1.3 2005/01/09 11:11:15 swegener Exp $
-
-IUSE="doc"
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdsp/libdsp-4.9.2-r1.ebuild,v 1.4 2005/07/13 14:25:11 swegener Exp $
inherit eutils
@@ -16,15 +14,11 @@ SLOT="0"
# -amd64, -sparc: 4.9.2-r1 - uses x86 assembly
KEYWORDS="x86 -amd64 -sparc"
+IUSE="doc"
DEPEND=""
S=${WORKDIR}/${PN}-src-${PV}
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
src_compile() {
# fixes some Makefile weirdness
epatch ${FILESDIR}/Makefile.patch
@@ -39,7 +33,7 @@ src_compile() {
sed -e "s:^PREFIX.*:PREFIX = ${D}/usr:" -i DynThreads/Makefile
# libtool only supports the --tag option from v1.5 onwards
- if ! has_version >= sys-devel/libtool-1.5.0; then
+ if ! has_version ">=sys-devel/libtool-1.5.0"; then
sed -e "s/^LIBTOOL = libtool --tag=CXX/LIBTOOL = libtool/" -i libDSP/Makefile
fi
diff --git a/media-libs/libdsp/libdsp-4.9.2.ebuild b/media-libs/libdsp/libdsp-4.9.2.ebuild
index de5c85bdb41e..2a56b66ae054 100644
--- a/media-libs/libdsp/libdsp-4.9.2.ebuild
+++ b/media-libs/libdsp/libdsp-4.9.2.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdsp/libdsp-4.9.2.ebuild,v 1.2 2005/01/09 11:11:15 swegener Exp $
-
-IUSE="doc"
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdsp/libdsp-4.9.2.ebuild,v 1.3 2005/07/13 14:25:11 swegener Exp $
inherit eutils
@@ -13,16 +11,12 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.tar.gz
LICENSE="GPL-2"
SLOT="0"
+IUSE="doc"
KEYWORDS="~x86"
DEPEND=""
S=${WORKDIR}/${PN}-src-${PV}
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
src_compile() {
# fixes some Makefile weirdness
epatch ${FILESDIR}/Makefile.patch
@@ -36,7 +30,7 @@ src_compile() {
sed -e "s:^PREFIX.*:PREFIX = ${D}/usr:" -i DynThreads/Makefile
# libtool only supports the --tag option from v1.5 onwards
- if ! has_version >= sys-devel/libtool-1.5.0; then
+ if ! has_version ">=sys-devel/libtool-1.5.0"; then
sed -e "s/^LIBTOOL = libtool --tag=CXX/LIBTOOL = libtool/" -i libDSP/Makefile
fi