summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Lashley <malc@gentoo.org>2005-01-11 02:44:46 +0000
committerMalcolm Lashley <malc@gentoo.org>2005-01-11 02:44:46 +0000
commit4af8b8ade2abce5e35a0d1fa22ff21fd28162228 (patch)
tree379f60cfa516e6a7f85ae3a3d03e733e48286211 /media-libs/libdv/libdv-0.104.ebuild
parent- fixed problem with missing ssp symbols. bug #76495 (diff)
downloadgentoo-2-4af8b8ade2abce5e35a0d1fa22ff21fd28162228.tar.gz
gentoo-2-4af8b8ade2abce5e35a0d1fa22ff21fd28162228.tar.bz2
gentoo-2-4af8b8ade2abce5e35a0d1fa22ff21fd28162228.zip
Bug #64331, Bug #51138, Bug #70062
Diffstat (limited to 'media-libs/libdv/libdv-0.104.ebuild')
-rw-r--r--media-libs/libdv/libdv-0.104.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/libdv/libdv-0.104.ebuild b/media-libs/libdv/libdv-0.104.ebuild
new file mode 100644
index 000000000000..96de9d603f24
--- /dev/null
+++ b/media-libs/libdv/libdv-0.104.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdv/libdv-0.104.ebuild,v 1.1 2005/01/11 02:44:46 malc Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Software codec for dv-format video (camcorders etc)."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://libdv.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gtk sdl xv"
+
+RDEPEND="dev-libs/popt
+ gtk? ( =x11-libs/gtk+-1.2* )
+ sdl? ( >=media-libs/libsdl-1.2.4.20020601 )
+ xv? ( virtual/x11 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.99-2.6.patch"
+ epatch "${FILESDIR}/${PN}-0.104-amd64reloc.patch"
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} `use_with debug`"
+ myconf="${myconf} `use_enable gtk` `use_enable gtk gtktest`"
+ myconf="${myconf} `use_enable sdl`"
+ myconf="${myconf} `use_enable xv`"
+
+ econf ${myconf} || die "econf failed"
+ make || die "compile problem"
+}
+
+src_install () {
+ einstall
+ dodoc AUTHORS COPYING COPYRIGHT ChangeLog INSTALL NEWS README* TODO
+}