summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-02 11:10:55 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-02 11:10:55 +0000
commit466058d61217f0d1b299309de0187eff0bbdeb52 (patch)
tree20e2b7e4dd4a962ef26cafc4e1b4b3b128da711a /media-libs/libemf
parentAdd ~x86-fbsd (diff)
downloadgentoo-2-466058d61217f0d1b299309de0187eff0bbdeb52.tar.gz
gentoo-2-466058d61217f0d1b299309de0187eff0bbdeb52.tar.bz2
gentoo-2-466058d61217f0d1b299309de0187eff0bbdeb52.zip
Handle static-libs individually, therefore move to auto-tools.eclass and EAPI=4
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libemf')
-rw-r--r--media-libs/libemf/ChangeLog8
-rw-r--r--media-libs/libemf/libemf-1.0.4.ebuild25
2 files changed, 17 insertions, 16 deletions
diff --git a/media-libs/libemf/ChangeLog b/media-libs/libemf/ChangeLog
index 0e19166c5ef6..e1395a9fba70 100644
--- a/media-libs/libemf/ChangeLog
+++ b/media-libs/libemf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libemf
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libemf/ChangeLog,v 1.33 2011/12/13 13:11:40 naota Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libemf/ChangeLog,v 1.34 2012/03/02 11:10:55 jlec Exp $
+
+ 02 Mar 2012; Justin Lecher <jlec@gentoo.org> libemf-1.0.4.ebuild:
+ Handle static-libs individually, therefore move to auto-tools.eclass and
+ EAPI=4
13 Dec 2011; Naohiro Aota <naota@gentoo.org> libemf-1.0.4.ebuild:
Add ~x86-fbsd
diff --git a/media-libs/libemf/libemf-1.0.4.ebuild b/media-libs/libemf/libemf-1.0.4.ebuild
index 9b1d2ae269af..2b55b28cb505 100644
--- a/media-libs/libemf/libemf-1.0.4.ebuild
+++ b/media-libs/libemf/libemf-1.0.4.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libemf/libemf-1.0.4.ebuild,v 1.8 2011/12/13 13:11:40 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libemf/libemf-1.0.4.ebuild,v 1.9 2012/03/02 11:10:55 jlec Exp $
-EAPI=2
+EAPI=4
-inherit autotools eutils
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
MY_P="${P/emf/EMF}"
DESCRIPTION="Library implementation of ECMA-234 API for the generation of enhanced metafiles."
@@ -14,23 +16,18 @@ SRC_URI="mirror://sourceforge/libemf/${MY_P}.tar.gz"
LICENSE="LGPL-2.1 GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND=""
+IUSE="doc static-libs"
S=${WORKDIR}/${MY_P}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-amd64-alpha.patch
- eautoreconf # or libtool tries to link against the gcc it was built with
-}
+PATCHES=( "${FILESDIR}"/${P}-amd64-alpha.patch )
src_configure() {
- econf --enable-editing
+ local myeconfargs=( --enable-editing )
+ autotools-utils_src_configure
}
src_install() {
- emake DESTDIR="${D}" install || die
+ autotools-utils_src_install
use doc && dohtml doc/html/*
- dodoc README NEWS AUTHORS ChangeLog
}