summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-05-06 16:15:36 +0000
committerPacho Ramos <pacho@gentoo.org>2012-05-06 16:15:36 +0000
commit53e521ff704bedaa6df5aea93c09e7f8ac32f353 (patch)
treed4b2c827fd27e7fee822b4bd68fbef8af0f3910a /media-libs/libirman/libirman-0.4.5.ebuild
parentlcd herd is empty (diff)
downloadgentoo-2-53e521ff704bedaa6df5aea93c09e7f8ac32f353.tar.gz
gentoo-2-53e521ff704bedaa6df5aea93c09e7f8ac32f353.tar.bz2
gentoo-2-53e521ff704bedaa6df5aea93c09e7f8ac32f353.zip
Version bump, remove old.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libirman/libirman-0.4.5.ebuild')
-rw-r--r--media-libs/libirman/libirman-0.4.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/libirman/libirman-0.4.5.ebuild b/media-libs/libirman/libirman-0.4.5.ebuild
new file mode 100644
index 000000000000..9d71c5acc507
--- /dev/null
+++ b/media-libs/libirman/libirman-0.4.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libirman/libirman-0.4.5.ebuild,v 1.1 2012/05/06 16:15:36 pacho Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="library for Irman control of Unix software"
+SRC_URI="http://www.lirc.org/software/snapshots/${P}.tar.bz2"
+HOMEPAGE="http://www.lirc.org/software/snapshots/"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+pkg_setup() {
+ tc-export CC LD AR RANLIB
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ dodir /usr/include
+
+ emake DESTDIR="${D}" LIRC_DRIVER_DEVICE="${D}/dev/lirc" install
+
+ dobin test_func test_io test_name
+ dodoc NEWS README* TECHNICAL TODO
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+}